All the npm of my bot have been uninstalled - discord bots


All the npm of my bot have been uninstalled for some reason and I can not install them. happens the error of the image that I sent and I can not solve it. Any help would be gladly.

copy paste, or run pnpm fix or something like that, i specialize in databases/compilers on glitch, so i don’t really know npm to well (except that glitch needs to update to the latest dev build)

i will look more into the issue, and open up a bug report to this support request

all done @YatoBot
you can find it here

Hey @YatoBot, you might try running enable-pnpm in the console, which fixes most transient (p)npm installation issues. If that doesn’t resolve it then most likely there’s amiss with your package.json file; please provide the contents of the file or your project name so we can take a look.

Still giving the same error in npm. I tried giving enable-pnpm but it did not solve anything, I also tried to give rewind in the project and still it continues.

his name is firo-chan and is currently private for my access only.

Hey @YatoBot, when I look at the logs pane for that project I don’t see anything amiss - everything looks to be working as expected. I do see the install error you mention, but that’s to be expected - the http package you’re requesting doesn’t have a version 0.0.1. I don’t think you need that package in any case - the http module you want to use is part of Node and doesn’t need to be installed.

One other thing - your project’s approaching the point where disk space is going to start causing you problems. Using du -hd1 in your project’s console shows that your git repo is what’s taking up most of your space. The post at Glitch full disk error shows the steps required to resolve this issue; you should take care of that soon before you don’t have enough free space to do the git cleanup described there.

1 Like