An all new Glitch editor

Here’s a bug that annoys me:

For whatever reason when you create a folder that has the same letter in the same position, it will replace the first folder you created and replace it with a duplicate of the second folder you created. For example, you create a folder called js/ and css/, the js/ folder will completely disappear and there are two css/ folders.

Also, why is the text white on project pages?

Thanks for continuing to report issues! They are all being looked at and bugs are being worked on… :bug: :building_construction:


it happened to me

luckily it doesn’t actually delete the files

1 Like

When i got on glitch i was aboslutley disgusted by the ui and im about to just look for another coding program and move all my websites to there because i hate this so much whoever came up with the new layout deserves to get fired

  • Renaming and other actions are now unchangeable in editor UI, very inconvienent
  • Things just look messier
    Seriously, we need an old editor option. Mainly because the new editor is not as good as the old one in many people’s opinion.
1 Like

Give us an option to revert back to the old UI. Also, make it so that we can change the name of the website in the same window. The edit button for the website title is gone.


ok it worked today – so either the universe tilted or you changed something ? i don’t know.

if you changed something, thanks!

still would prefer this in the main tab but being able to actually name projects is a big win.

Glitch won’t tell you if the name you want is already taken, which is quite annoying. If it redirects to something that isn’t your project, that name is taken. Archived and private projects with the same name will show “can’t find <name here>”. I hope there is an update coming that will allow users to see if the project’s name is taken before you click save and redirect and all that, but for now, you just have to hope the project name you are trying to set it to isn’t taken.

Hopefully this helps.

1 Like

You didn’t finish the archive feature on the product page - it just copies to clipboard.

Thanks for reporting! This is fixed now.


when will this be fixed?


I wish you could revert to the old editor, or not have the UI so bulky and half-finished. It really sucks.


I give an example of glitch getting stuck when I create a folder after the last view customization it just introduced

When I write struct/Client/Client.js the website freezes, I have no problem with myself.

Highly agreed :sleepy:

I know right, the editor is really annoying an hard to use…

It’s better if you add the choice of changing between new or old UI, some people liked the new UI but most aren’t, so adding a button to switch is very good.

1 Like

How do I add projects to a team on Glitch? - Glitch Support (

There used to be a way to join a project when you’re in its team, a dedicated button in the editor. Looks like that didn’t make it into this new UI. Will it be coming back in the future?

If you are working on mobile when on-the-go, the only way to see the text in the editor is to click on the bottom of the screen on the preview button then click the close preview pane, which is very annoying.

that was temporary – back to not working.

@hman124 thanks for the tip. it still doesn’t work for me – i am trying odd prefixes to ensure its unique but has only worked once.

So, in the new editor, I opened the tools bar as usual,
I opened custom domains, then I clicked the little arrow to go back, it went back to the “legacy” toolbar.

This also works with the Import/Export, however, it does not open with Rewind.
It looked like this
Screenshot 2022-01-11 12.15.23 PM

This might be intentional, but I highly doubt it.

1 Like