An error occured in my project and now it has a lot of bugs and does not have any files

Project name is diep2- .
Yesterday, I went to check it out, wanted to work on it, so firstly I went to it’s website to see how it looks again. First off it was written “Waking up…”, but it lasted like that for a while and then did not change to “Starting…”, but instead to something else I don’t quite remember now. As it was my first time seeing such thing, I went to the glitch page to open up my project, but I couldn’t see any files. None, not even .env. So I opened up the console to see what’s going on, and there was this error which was something like “Failed to move directory /*something_similar_to_remote to /remote - the directory is not empty”. Later on it just kept loading and loading the project, I couldn’t even remix it, so I left it over night (the incident happened yesterday).
Today I decided to check it out again, and what do I see? No files at all, project’s page loading but in uncommon way, showing “Listing ~ directory”, what is this even supposed to mean lol. Where are my files? I tried rewinding the project, remixing it (this time successfully but the copy doesn’t have any files either, guess it’s some file system problem, but I don’t want my files from the project being deleted), but rewinding did not show ANY past points before “Now”, and when I tried to move back the slider, the whole glitch page broke, did not display any UI, just the background.
Now I’ve noticed there is the .env file, but I totally can’t even open it. Can click on it, but it does nothing.
The console does show something. Message telling me at what IPs my project is running.
“Serving at http://189bbb7d4c99:3000,,
Or rather the server, I don’t know. The project (diep2-) is a server with a website, or at least, was.
Please, files in here were important to me. I don’t want to loose them. Nothing like that has ever happened to me before.
If you have any more questions which I did not explain here, feel free to ask.
Update: I forced refresh from the console, now I don’t even see the .env file. Nice.


I’ll ping @glitch_support for you so they can retrieve a backup of your project.

1 Like

Same, my project’s files are also gone. Did something happen in the glitch’s server?

Have you tried rewinding?

Yes. It is written in the post.

Try contacting the support email and ask if they can rollback your project.

Do not edit your project more!

Possibly relevant, Is Your Project Suspended / Code Missing?. @tasha please lock this topic and merge it with the mega thread!

1 Like