An error occurred when trying to create this project, please try again later

I am trying to remix this: https://glitch.me/edit/#!/okta-conf-avbank

It’s a project I created. If I am logged in as myself, it works.

But, if I am not logged in at all or logged in with a different account, it fails with the above error message.

I’ve used this project a lot in the past without this issue.

I created a developer challenge for Okta at conferences we sponsor and this is the first time I’ve run into this issue.

You can see the challenge with the glitch project link embedded at: https://springone.oktachallenge.dev (click the Tier 2 tab)

Thanks for any assistance!

Hi @dogeared, welcome to the Glitch forum!

I’m able to reproduce this issue in at least some conditions and will pass this along to the rest of the team. I don’t seem to be able to reproduce this in any Remixes of your source project; if that’s true for you as well then I suggest Remixing the project and juggling names so the link in your docs points to a project that’s working as expected. In fact, since I can’t reproduce this in Remixes from your project it would be handy for us to have this specific project around to test with - it would also be interesting to see what happens when Remixing from this project after it’s been renamed, for instance, but I don’t want to muck about with your live project.

Sorry for the bother!

huh. ok. let me try to rename the busted version, create a new remix from the working source, and rename that to this one and see if it all hangs together :wink:

Thanks for looking.

Here’s what I did:

  1. while logged in, remixed the problematic project: okta-conf-avbank
  2. renamed okta-conf-avbank to okta-conf-avbank-busted
  3. renamed the new remix to okta-conf-avbank

Now, in an incognito window when I try to remix the new okta-conf-avbank, I am still getting the error.

When you say: “I don’t seem to be able to reproduce this in any Remixes of your source project…”, what exactly were you talking about?

Thanks!

Hey @dogeared, thanks for the additional info and testing.

My experience is that I am able to Remix either of those projects without being logged in, receiving the error we both encountered but otherwise successfully (after refreshing my browser). Once there I can Remix those Remixed projects without any errors, but that doesn’t sound like what you’re experiencing. I haven’t been able to specifically identify what’s causing the error yet.

dang. ok. I will try to recreate the project from scratch and then rename it if it works. In the meantime, I’ll tell the folks running the booth at the conference were sponsoring to advise people to just refresh the page. Thanks.

BTW, I am seeing the same behavior with: https://glitch.me/edit/#!/okta-conf-hooks

Per your comment, if I acknowledge the error and refresh, the remixed version is there. Any idea what’s going on with this? There are other upcoming conferences we were planning to use this developer challenge app for. Thanks!

I haven’t been able to isolate this yet, I’m afraid, but I’m still investigating - do you mind if we “take over” ~okta-conf-avbank-busted for deeper investigation (we may need to do things like rename it or make other changes to see if we can sort out what’s going on)? Normally I’d just work from a Remix, but in this case Remixes don’t seem to exhibit the same behavior (at least not for me) so working with a known-broken project might help, but I don’t want to mess with that project without your explicit approval.

yes, feel free to take over okta-conf-avbank-busted. Thanks!

Hi @dogeared thanks for that. We think we’ve sorted out the root cause, but I’m not exactly sure when a fix will be available. I’ll let you know when we release it so you can take a look.

Thanks! FWIW, I have not been able to get it to work cleanly. I tried exporting it to a git repo and then reimporting as a different user and got the same result - error, then seeing the remix if I refresh.

Is it something in the code I could work around or refactor?

Nope this was definitely a logic problem on our end. We think we’ve resolved it, and I can’t reproduce it any more in some light testing; can you give it a try and let me know how it goes?

confirmed! It’s working now. Thanks!

1 Like