Assign a .tk domain to a Glitch project

Hello! I am wondering if I can assign a .tk domain to my Glitch project (

I have tried to get CloudFlare to link my Glitch project domain but I get a Please ensure you are providing the root domain and not any subdomains (e.g.,, not (Code: 1116)

Thus, when adding the .tk domain I get a is not a registered domain (Code: 1049) error.

How can I connect my Glitch project to a .tk domain then?

The owner of .tk domains is Freenom. They don’t allow you to enter a URL to redirect/foward to. Only IP addresses are accepted.

Any help would be appreciated :pray:

We don’t support custom domains yet ourselves, but you can set one up using a third-party. We recommend as they make it super easy and have a glitch option.

I have tried that but asks you to point your domain to a URL. Thus, freenom doesn’t support records pointing to a URL. Also, fly projects can’t be accessed just by their IPs.

You can get the IP for the address it generates by pinging it. Then use that record in an A name record. That’s how one of mine works.

That didn’t work for me. Here’s a video showing you what I did:

Click here for the video

Sorry if my screen recorder didn’t record with a good frame rate.

Otherwise, do Glitch projects have their own IPs? I don’t mind if it changes every time my app restarts.

1 Like

You did right up to and including getting the IP address. You then need to go to your domain name registrar’s site and create an A name record for your domain using that IP address. It doesn’t matter that you can’t access your site when visiting the IP itself, it isn’t unique to you.

Glitch apps don’t have a unique IP address and can change at any time.

1 Like

Thank you for your help! I have sucessfully got my project ( running on the domain:

Thank you! :grinning:

I also made a post explaining how to get your own custom domain!

You can find the post bellow:

1 Like

Great news, and that’s cool - thanks for putting that together!

1 Like

Did sites get removed from

I think just the link did, last time I checked you could still access the page at

1 Like

Ah Thanks, that helps alot!

Whenever I go to add my hostname, it gives this error

That domain is already registered with

For the time being, I know it isn’t ideal, but you can also use a redirect, so when users go to they go to the site.

Thanks @jdc20181 and @charliea21, I have fixed the error a long time ago, the problem was the domain was linked to a deleted glitch project!

1 Like

I wanted to use freenom, but I failed due to the fact that Google Recaptcha is blocked in china.

Could try using your browser to a proxy server or through a VPN. An easy way to try this is the Opera browser, which has a free VPN built in (except not on the mobile version I think). I’m guessing they get paid by selling your meta data, might still be worth it.

The momment my ISP sees this, they will block the opera download site