Awk: line 1: syntax error at or near , Could not find node 10.x, using 10

I was told this error is from glitch and not my code.

awk: line 1: syntax error at or near ,

Could not find node null, using 10


awk: line 1: syntax error at or near ,

Could not find node null, using 10```

Hi, in my console, I’m getting this error:
image

I’ve tried switching to 10.15.03, but I get the same error.
Any help is appreciated.

Getting the same error since yesterday, but only in 1 of my projects.

It has been happening ever since i updated one of the dependencies

same problem here… started a couple hours ago…

glitch project: hadesbotty

I remixed my project and it was fixed.

Hey y’all, we briefly released a bug causing this earlier today. We’ve since reversed the change, but your projects may not have gotten the fixed code. We can resolve this for you, but we need to know your project name. Please post your project names here and we’ll fix them up as soon as we can.

If you just wait, within another 7-8 hours any project that’s seeing this error should have restarted and have the fixed code.

Sorry for the bother!

If you could fix project: frozen-island

Thanks!

Project name: kuron-bot

Project name: megubot-main

Project 1: militarycemetery
Project 2: multichan

Please fix ally-automate

Project name is “ayanami”

Project Name: nate-bot
I have developer/test bot that I run and please fix that one also: natebotdev3

mythical-bots
koala-advertising
mythical-bots-servers
mythical-moderation

All of these projects above are having the same issues as everyone else.

This happened on three different hosts.
reward-bot
cgc-kittybot
eventmanager

pls fix: sabundles

Project name is “willybot”
please fix

sprawlbotjs is also experiencing this issue.

Hey @insannityxd and @ShimaHaucksDeveloper, welcome to the Glitch forum!

For both of your projects, and yours @glewmie, the message you’re seeing isn’t the one folks were seeing earlier, although it’s very similar. This one is expected and harmless; it’s really a warning and not an error, which is why you won’t see the “Error” beacon in the Tools / Logs button. This is Glitch making sure you know that since you didn’t tell us which version of Node you wanted we’re choosing for you and will use the default version (currently 10.x).

If you want to make the message go away you’ll need to explicitly tell Glitch what version you do want to use, which you can accomplish by adding an engines stanza in your package.json file which would look something like this:

  "engines": {
    "node": "10.x"
  }

Put that anywhere in package.json (and set it off with the appropriate comma depending on where you put it) and the message should disappear.

Sorry for the bother!