"better-sqlite3": "^4.1.4" not working


#1

FATAL ERROR: v8::ToLocalChecked Empty MaybeLocal.

1: node::Abort() [node]

2: 0x8cbf4c [node]

3: v8::Utils::ReportApiFailure(char const*, char const*) [node]

4: Require(v8::Local<v8::Object>, char const*) [/rbd/pnpm-volume/a7bbfe21-8ca0-43a0-8528-1f85f07013c0/node_modules/.registry.npmjs.org/better-sqlite3/4.1.4/node_modules/better-sqlite3/build/Release/better_sqlite3.node]

5: Integer::Init(v8::Isolate*, v8::Local<v8::Object>, v8::Local<v8::Object>) [/rbd/pnpm-volume/a7bbfe21-8ca0-43a0-8528-1f85f07013c0/node_modules/.registry.npmjs.org/better-sqlite3/4.1.4/node_modules/better-sqlite3/build/Release/better_sqlite3.node]

6: RegisterModule(v8::Local<v8::Object>, v8::Local<v8::Object>) [/rbd/pnpm-volume/a7bbfe21-8ca0-43a0-8528-1f85f07013c0/node_modules/.registry.npmjs.org/better-sqlite3/4.1.4/node_modules/better-sqlite3/build/Release/better_sqlite3.node]

7: 0x8cd92d [node]

8: v8::internal::FunctionCallbackArguments::Call(void (*)(v8::FunctionCallbackInfo<v8::Value> const&)) [node]

9: 0xb0bbec [node]

10: v8::internal::Builtin_HandleApiCall(int, v8::internal::Object**, v8::internal::Isolate*) [node]

11: 0x20a044a042fd

How to fix this error?


FATAL ERROR: v8::ToLocalChecked Empty MaybeLocal
#2

My friend have the same problem


#3

I haven’t been able to reproduce this. How are you installing the package and which version of Node are you using?


#4

I have this issue, the bot worked just fine until last night when it started saying it couldn’t find express then I tried to reinstall express and this happened. I have no idea what happened. Please help ;-;!


#5

See my response to your thread: Fatal error please help