Can not create a new Filein Project


#1

Hey guys,

first of all, i love glitch and i think it is one of the best projects for the last couple of years! :heart_eyes:

Anyways … i have a project: tvcharts.glitch.me / https://glitch.com/edit/#!/tvcharts
And i wanted to add ejs-Templates to it.

I started on friday and the first template made no problemes at all ( views/pages/index.ejs ).
Inside i tried to load partials, but … no chance.

I can not generate a new file. I can click the button, and it is shown in the interface, but i can not edit it.
After a while glitch tells me that i can not reconnect and i should reload.

After that the file is gone!

So i am not able to add more files to this project, and this is where i stuck.

Can anybody give me an advice.
The File i wanted to generate should be located ( views/partials/head.ejs )

THX*woo


#2

It looks like the file ‘partials’ in views is confusing things. I could re-create similar issues, but removing that file and reloading the project seemed to help and the index.ejs was then able to render from the included partials ok.

We’ll look into why.


#3

@Gareth, thank you.

the path /views/partials is now without any file inside in the editor available after tons of tries.
But as you mentioned the problem is not solved with it.

Please keep me updated.

Thank you a lot, and once again great job, great service, i love it!


#4

I’m not sure you’ve understood. I’m suggesting removing ‘views/partials’ from your project. I can still see it in yours. Only after removing that did it then work ok for me.


#5

no i didn’t get you right. deleted it now!

works like a charm now. THX!