Cannot file module ../build/better_sqlite3.node [SOLVED]

Hello, i need help for my project.
When I just woke up, I saw an error in my project.

throw err;
^

Error: Cannot find module ‘…/build/better_sqlite3.node’

at Function.Module._resolveFilename (module.js:548:15)
at Function.Module._load (module.js:475:25)
at Module.require (module.js:597:17)
at require (internal/module.js:11:18)
at Object.<anonymous> (/rbd/pnpm-volume/1f5d0e3c-b57d-430e-8063-e3c58a5830f5/node_modules/.registry.npmjs.org/better-sqlite3/5.0.1/node_modules/better-sqlite3/lib/database.js:5:21)
at Module._compile (module.js:653:30)
at Object.Module._extensions…js (module.js:664:10)
at Module.load (module.js:566:32)
at tryModuleLoad (module.js:506:12)
at Function.Module._load (module.js:498:3)

Can you help me to fix this error, please?
Sorry for bad grammar.
Thank you.

I got the same issue. But mine was cannot find module discord.js.

Hi @H29id, welcome to the Glitch Forums!

For both your problem and yours, @klerikdust, I would suggest running enable-pnpm in your project’s console (which you can reach from the Status pane revealed by clicking the Status button under your project’s name in the editor).

Let me know how you get on and we can troubleshoot further if need be.

Thank you for reply me, there are no changes to my project, the error was not fixed

That’s not necessarily relevant based on the way projects can be restored from cold backup. enable-pnpm will trigger a reinstall of the project’s node modules which may resolve the issue.

1 Like

Fixed, thank you for helping me @cori :smile:

I have the same issue, but enable-pnpm doesn’t fix it. @cori

1 Like

Hi @HawkeyNL, welcome to the Glitch forum! Sorry for the bother!

Can you provide your project name so someone can take a look?

1 Like

I already fixed it, but ty.

1 Like

@cori Could you come and take a look at my project and see how this can be fixed, I have had this problem for the past 2 hours now and cannot get it fixed no matter what I try. Project name is: cmb

This had started off when my logs were once again telling me I did not have express installed when I clearly did.

Hey @Callum-OKane I resolved the error you were seeing by adding node-superfetch directly to your project’s package.json. There’s now a different error message seemingly unrelated to installation. I added that package in the laziest possible way, using “*” for the version definition, so you might want to change that to a more specific version at some point.

1 Like

2 posts were split to a new topic: Node-opus bindings file not found