Cannot find module 'merge-descriptors' error

I am having an error:
Error: Cannot find module ‘merge-descriptors’

10:47 PM

at Function.Module._resolveFilename (module.js:548:15)

10:47 PM

at Function.Module._load (module.js:475:25)

10:47 PM

at Module.require (module.js:597:17)

10:47 PM

at require (internal/module.js:11:18)

10:47 PM

at Object. (/rbd/pnpm-volume/fcd98a19-5ef7-4bcc-8d40-37ab7aeed9c3/node_modules/.registry.npmjs.org/express/4.17.1/node_modules/express/lib/express.js:17:13)

10:47 PM

at Module._compile (module.js:653:30)

10:47 PM

at Object.Module._extensions…js (module.js:664:10)

10:47 PM

at Module.load (module.js:566:32)

10:47 PM

at tryModuleLoad (module.js:506:12)

10:47 PM

at Function.Module._load (module.js:498:3)

With my bot code. I think it’s something with express, and i can’t figure out what is wrong. I looked at this post, and they said that it fixed itself.

My friend is also having this issue with his bot. This has been happening since Saturday.

My project name is meow-bot. It is working on all of my other bots.

Hey! Missing modules errors can be resolved by doing enable-pnpm in console which will force restart installing all packages.

2 Likes