Cannot "git pull" anymore from Gitlab: "connection timeout"

Hello there :wave:
For a few days, I can not use git pull anymore from the console of my projects, I’m only receiving “connection timeout”.
See for example

I reached Gitlab as well, but the problem does not seem to come from there.
Any idea?

odd… i am going to try to reproduce this myself, can you tell me the steps to reproduce?

If you remix, the origin remote should still be the same, therefore you should be able to try “git pull” from the console and see the same problem

odd, it is taking much longer than usual?

i got it!

yes, from the looks of it, it is not a memory problem, it is a network problem, something is wrong with the way the containers are configured, they were updated from my knowledge 1-2 weeks ago, so they can withstand some new updates, which you can see on the container stats page of the project.

Great, seems to correspond with the last time I could pull!

i can do some more digging and see if i can see if this is a network forwarding problem, because all requests to outside websites from the glitch container do go through 1-2 servers for processing due to how large the glitch database is, so that can also be a factor aswell!

well, none of the apis i created are down, and i can access them from within the container, and through an external tool, so i would say it maybe an issue with network forwarding

haha, way above my knowledge but thank you a lot for investigating this issue :pray::pray::pray:

1 Like

Hello @J-Tech-Foundation :wave:
Could you figure out the issue? Any idea if this will be fixed?

after 3-4 hours, i was able to do so, it just may be how the project is set up?

Not sure about what you mean by the project setup?
Just tried with a brand new Glitch project with web page template:

  • opened the console
  • added remote origin: git remote add origin
  • tried to pull: git pull origin master --force
    :arrow_right: fatal: unable to access '': Failed to connect to port 443: Connection timed out
    I am doing something wrong? It used to work :sweat_smile:

very odd…

very odd

I’m using this setup for months to automatically pull updates from Gitlab, using webhooks (see and this is down for every projects with this same setup for a few days…

1 Like

This thread Import/github URL not working -- sets up default express demo instead may be related to the same issue

yes, it seems so!

i will try a few other things to see what i can do!

Same case for me. Is this issue on Glitch’s container side?

It seems so, last time I could pull was February 21st :disappointed:

This works just fine!!!
Thanks @Glitch_Response :pray: