Cannot load certain modules (enmap-level and enmap-rethink)


#1

Hey there, this is the first time that I have came across this problem. But for some reason I cannot load the modules: enmap-rethink and enmap-level. My app is for a discord bot, the app is called klink-bot. I have no clue what is going on, I tried changing to specific versions, changing them to the newest versions swapping them round in package.json but nothing


#2

What error messages are you seeing in the logs? I was able to install those packages so it seems like it’s something project-specific. Since your project is private can you DM me a join link or make it public?


#3

Yeah I probably messed something up haha,
and this is the log messages:
Error: Cannot find module ‘enmap-level’

at Function.Module._resolveFilename (module.js:489:15)

at Function.Module._load (module.js:439:25)

at Module.require (module.js:517:17)

at require (internal/module.js:11:18)

at Object. (/app/index.js:2:20)

at Module._compile (module.js:573:30)

at Object.Module._extensions..js (module.js:584:10)

at Module.load (module.js:507:32)

at tryModuleLoad (module.js:470:12)

at Function.Module._load (module.js:462:3)

#4

Can you tell your node version in your project.
Because I too had similar issue but with some else project and lately realized myself that it was some issue with node version.
My issue was solved when I downed the node version to 8.6.0 or 8.6.2 for 8.9.x and my issue was solved.


#5

In this case, we resolved it by removing node_modules and forcing it to build again. I imagine changing Node version causes a similar thing too.


#6

Well believe me,
Try installing the github branch of discord.js and klasa in node 8.9.x and then again with 8.6.x.
You will notice the difference.


#7

all works now, I’ll keep that in mind though