Cannot open glitch

I cannot open my glitch editor and website unless I use vpn

Is this a very strange behavior that you have already tried to change your browser?

yep! I tried everything

What do you mean by not being able to open the editor (white screen? it doesn’t load at all? project doesn’t appear?) Any errors in the console? Maybe try clearing your cache or hard refreshing

Dude I can only open if I’m using vpn

What do you see if you don’t use a VPN?

It was not earlier but it’s happening from 4 days

well the box where all your recent projects display it keeps loading
and the profile page also keeps loading and when I open editor it opens a alert box and says to refresh the editor

Just note that Glitch is currently recovering from API issues.

Well I my ISP is airtel and I tried to open it from every airtel internet in my home availabe none of them worked

Is Glitch blocked on Airtel?

From 3 days I’m facing same issue I cannot open the editor of my project and when I try it says to refresh the editor, why daily I’m facing this issue

hi there - your ISP may be blocking glitch. I’d reach out to them to see if they have recently changed security settings that would block us for some reason.

1 Like

Do you know anyone else with Airtel? Ask them if they can access Glitch. If it doesn’t, it’s Airtel’s issue. If it does, It’s probably an issue on your end.

1 Like

one of my friend uses airtel and he can open glitch

Try checking your router settings, or reset your browser. Maybe it’s your antivirus detecting something on and blocks it. That is my advice.

Well first of all I don’t have wifi second my antivirus plan explored a week ago

Are you using anything like Pi.hole that allows you to block certain websites and that is blocking it? Try changing your DNS server: or Change it to and (Google DNS) or (CloudFlare DNS) Edit: Just gonna explain what this means. This means that instead of routing your internet traffic through your ISP (who may be blocking Glitch) it will route through another service like Google DNS or CloudFlare - some people use this to bypass blocks from their ISP or to get a faster internet speed

Maybe it’s an issue on your end. Check your computer, antivirus, firewall, web filter, and anything else that could be blocking Glitch.