Can't find the URL

I don’t know if this is the correct tag, but I need help, so…
I was checking if my website was online (, but it keep saying me that the URL of the site can’t be found. I tried from my mobile phone, PC and dad’s phone and it doesn’t work, but on my friend’s phone (they aren’t even from my city) it works.
Then I realized that I couldn’t open any glitch-hosted project!
Can you help me solving this?
EDIT: I’ve tried both over mobile data and WI-FI, still nothing

I can easily access it, maybe the issue is with you ISP blocking the website, if you use same for wifi and mobile data that’s probably it. If you don’t, I really don’t know the issue.

EDIT: Could also be a country ban, check your .htaccess if you have it.

Hi @GianlucaTarantino, welcome to the Glitch forum!

As previously noted this seems like you might be being blocked from accessing Glitch somewhere along the line. I’m a little surprised; I know we have folks using Glitch located in many places and I have yet to hear of this wide a ban. We have had folks blocked from using Glitch on their work network in the past, for instance, but switching to mobile data showed they could access it there and they were able to work it out with their network engineers. However it sounds like you’re being blocked there too.

Unfortunately there’s not much we can do to help with this - it’s not really a Glitch problem. I suppose you might be able to use some sort of VPN to access Glitch, but I don’t know what might be available to you on that end.

It seems as though you’re able to load the Editor though, correct? Is it just addresses you can’t access? If so, perhaps you could use a custom domain to get around that limitation?

@cori would it help to follow up if @GianlucaTarantino sent you a message with the country, city, and names of the internet service providers?

That might help clarify things, but it won’t get us any closer to a solution for them - Glitch doesn’t have any way to influence or effect change in network- or ISP-level issues.