Can't import a github repo

i was trying to import a github repo to my project but it always fail, tried revoking access then grant it again but still fail, does this have something to do with repo being private?, it says on Importing Code from GitHub - Glitch Support that importing private repo requires authentication, where can authenticate?

Hi @DevMoh

Here are two common causes for this issue:

  1. The GitHub account that you are trying to import from is already associated with a different Glitch account.
  • If this is the case, then you will need to either use that other Glitch account to import the repo or remove the GitHub account from the other Glitch account.
  1. You have more than one GitHub account and your browser is trying to apply credentials for a different GitHub account when you attempt to import code to Glitch.
  • To fix this, clear your browser cache and then try the import again.

If neither of these solutions work for you, send us a support request. We will be happy to help you further.

1 Like