Can't import from github repo

Can’t import from my Github repo. Tried importing to a new project too and it says repo can’t be found. I copied the import path directly from github so there can’t be a typo.


Hey @aaronmassey45, sorry for the bother!

Looking at our logs I see that the issue when trying to import to oasis-atom is that our import process can’t remove the client and server directories, so a quick workaround would be to remove those directories using the project’s console and then to try again.

I can’t reproduce the issue on a new project, however; can you provide the exact error message you’re seeing?

I also can’t get a project I imported from your repo in the same state that oasis-atom is in - after repeated attempts I’m still able to import. I see that the server directory on oasis-atom has a node_modules directory inside it - do you know how that got there?

Removed those folders and it worked.
However I can’t get the project to work now and I can’t see the logs, only shows the console to run commands.

I have no idea how client and server got there. I was wondering myself. I don’t see them under files but when I use the ls command I see them there with a node_modules folder

Currently says I’m running out of disk space but I can’t see files/folders that are causing this extra space

Hey @aaronmassey45 glad you got the import working.

The logs pane toggle between the Logs and the Console, so if you’re seeing the Console and want to see the Logs you can click on the Console button to switch back.

When I open that project I see the client and server files that are coming from your repo. The repo doesn’t have the server/node_modules folder in it though; that’s the one I was curious about.

Now that I look at your new project I’m even more confused than before - I don’t know where the .npm or .pnpm-store (which is the one that’s taking up all the space) directories came from. When I import that repo and let Glitch do its thing I don’t see either of those directories. Can you help me understand your process for this project after the repo’s been imported?

Unless there’s something special you need, I’d suggest removing both of those directories and running enable-pnpm in the console.

Let us know if that helps clear things up!

When I finally got my repo imported and could view the logs, I got an error saying express wasn’t found in my server folder so I ran pnpm install and it cleared that error. Then I couldn’t see my front end because the React project wasn’t built so there wasn’t a build folder to direct to. I tried to run the build script in my client folder but it said react-scripts wasn’t found so I also ran pnpm install in there as well.

Ah, that’s helpful info, thanks!

I’d like to explore this a little more - when I import your repo and set up my own config info in .env it seems to start right up with no manual installation steps needed. If you start over again do you still run into the same problems? If so, are they resolved by running enable-pnpm?

I still run into the same problems. It happens on all of my projects. I’m not sure how you’re getting it to run with no extra steps :confused: