Can't import model with mtl file


#1

I’ve been trying to import a model with an mtl. I made both in magicavoxel and have had trouble with the mtl. The model looks fine and I was getting a warning: Material component properties are ignored when a .MTL is provided. I was able to fix this by switching to v.0.6.0 however the mtl still doesn’t work.Any help is greatly appreciated.

https://gamy-duke.glitch.me/


#2

You might want to try adding the files to the editor, rather than as assets and using the local path to the file. This is a working example project that makes use of MTL files in this way: https://glitch.com/edit/#!/lavish-night


#3

I tried replicating the project you posted. I made several files called public/resources/…mtl and public/resources/…obj. In these, I have the Absolute path to the file saved in a variable. I then reference this variable when making the object. This still isn’t working. I feel like the solution should be very easy but I have been struggling with this.


#4

It looks like you’re using the path to the asset you have saved locally on your computer. Since the asset is being referred to on Glitch, it doesn’t know about your computer or how to access it. When I suggested using a local path, I meant local to the Glitch container. Since the example I provided is working, I suggest remixing it and customising that project, updating it to use your own MTL files.