Can't use or edit one of my projects today (500/502 errors)


#1

I’ve used this project daily for many months without issue. Today the live site returns a 500 status with “Routing error”.

Editing fails with a red message “Hmm…We’re having trouble connecting. Try refreshing?”. Incognito window same thing. Console shows something like:

reconnecting-websocket.js:206 WebSocket connection to ‘wss://api.glitch.com/XXXXXXXXXXXX/ot?token=XXXXXXXXXXX’ failed: Error during WebSocket handshake: Unexpected response code: 502

The project name starts with “anthonys-per…”; I prefer not to share the full url publicly, but I can directly message an admin if you can’t find it and need to restart it.

Related findings


#2

Exact same behavior with one of my projects, as of today.


#3

Same here as well. I’ve had relatively stable connections all day, but suddenly all of my projects are experiencing the same issues described.

[EDIT - 4:33pm EDT] All my projects are back up and running now!

[EDIT - 4:50pm EDT] All my projects are down again. :confused:


#4

Yep, lots of 504 timeouts for me. Editor keeps losing connection and app sites won’t load at all :frowning:


#5

Hi all, this is an issue on our end with our servers currently straining with new activity. We’re really sorry about troubles connecting to Glitch right now.

We’re looking into the causes now, and will later post a downtime report about the cause, fix and what we’ll be doing to mitigate this issue in the future.


We are having trouble connecting. Try refreshing
#6

We think we’ve found the cause, so for now performance should be back to normal but we’ll continue to monitor and will be applying fixes to stop this happening again.


#7

I’m having an issue with my project as well - tries to reconnect and then says “Hmm… we’re having trouble connecting. Try refreshing?”. A couple of my other projects seem to be working fine, but this one seems to be dead (which is unfortunate given that it’s the one I’m using in production)


#8

Same with my project too, I tried remixing it into a new project and use it for the production but the new one gave “reconnecting… there is a problem” too, it’s been down for last 3 days it seems. I hope it gets solved soon. Go Glitch fixers!
EDIT: Thanks it is back up! :smiley:


#9

@Trion129, @joellabes,

we are sorry for the inconvenience. Your projects should be back now!


#10

I just checked this morning and my project is working again :grin: Thanks everyone!