Capability to toggle automatic update of active application


#1

During a coding session we are able to run an instance of the project choosing the “show” function. Unfortunately when an instance runs it seems edition becomes difficult and painful (focus lost etc.)

May be a toggle like enable/disable automatic application update can be helpful. In addition a synthetic view of running project (last deployment/update, running or not, monitor stuff (?)) can be a plus.

May be this is related to “Rebuilding on every keypress + logs window open = frequent lockups” feedback.


#2

Hi :slight_smile:

If you sign in, under your profile menu there will be an option “Refresh App on Changes”. If you disable the checkbox you have to hit “Refresh” to see the changes.

Does this solve your problem?


#3

Hoops sorry don’t see this option. Yes this is exactly what I’m looking for.
I tried it and it seems the application still refreshed each time i hit a key :neutral_face:!


#4

I think it stops the browser refreshing the app (the one launched with the Show button) but not actually rebuilding of the app on keypresses?

I think it could be good to either throttle so it only builds after no keypresses for a period (at least a few secs!) or (preferred) have an option to just stop all the building entirely until you click the Show button/press Ctrl+Shift+R. It’s quite distracting even having the Logs button animating while trying to churn out a big class, and sometimes you might want to interact with the app, and just stopping it refreshing doesn’t stop the server being pulled down.

It feels like my code is compilable < 10% of all keystrokes so build-on-keypress seems like a bad use of resources.


#5

Where is the “Refresh” button? I can’t find it… Is it referring to refreshing the browser window the app is open in? A keyboard shortcut would be nice, too.

I’'d like to disable automatic updates, then manually rebuild/deploy the app because:

  • They are distracting
  • Often update right before my final key strokes, so the final version isn’t even deployed
  • I have this feeling automatic updates are causing my projects to stop working (404/503 errors).

#6

You should be able to disable the auto-refresh by clicking on your user profile image in the top right, then deselecting “Refresh App on Changes”.

Another alternative is to navigate to your app directly rather than using the preview window created by “Show”. You will be able to manually trigger refreshes by reloading the window yourself.

Hope this helps!