Cloning repo doesn’t work -- “authentication failed”


#1

So I’m trying to clone my glitch project to my computer using git clone “project name”. However, after putting in my project name and username/token, it asks for a password. The git import/export options says the password is an empty string, but when I press “enter” it just says “authentication error.” I tried it again with the password just a space, but the same thing happened. What is going on?


#2

Hey @CarlyRaeJepsenStan sorry for the bother!

Are you using git clone on the command line, or are you using a tool? if a tool, which one? What operating system are you on?

Also can you share your project name so we can test it?


#3

Hi again Cori! I am using macOS. At first I tried using Atom (the text editor) to clone it, and then I tried the command line. I’m not so sure about giving out the project name because I have my token in an unprotected config file. Is it possible to private message you? Thanks for trying to help!


#4

If your project is private then no one you don’t explicitly invite will be able to see your code (aside from a few Glitch staff members).

If you’re more comfortable sending a PM that’s fine; you should be able to message me from my avatar. Or you can email support@glitch.com.


#6

Have you tried cloning from the glitch console? It usually echos something like “Enter password” or something


#7

Leave the password field blank!


#8

Hey @CarlyRaeJepsenStan I think we’ve isolated the bug that’s causing this. I don’t know yet when I fex will be ready, but I’ll update here when there’s more news. Sorry for the inconvenience!


#9

Hey @CarlyRaeJepsenStan our most excellent team just pushed a fix for this bug; can you please give it another try and let us know how it goes?


#10

Thanks so much @cori and the support team! It works now!!
I am curious, though… what exactly was the issue?


#11

There was a disconnect between the git username in the Editor and the repo authentication on the backend.


#12

:thinking: I see. I suppose that’s why a password dialog appeared.


#13

Well, I’d’ve expected you to get the password prompt no matter what, but that’s why authentication failed.


#14

Hm that’s strange, because when I cloned it again after the fix was pushed no password prompt appeared.


#15

If your project’s git repo’s remote was set properly then it wouldn’t need the prompt, so that’s probably what happened. If you look at git remote -v the remote should have your git username in the url.