Commits made from glitch console not attached to my github user


#1

I have added my email using
git config --global user.email "myemailaddress@email.com"

I have confirmed that it was added correctly (git config --global user.email returns my email)

I have also tried to store my credentials so I don’t have to re-enter username & password each time I push:

git config credential.helper store

but this doesn’t seem to work.

In any case, all of the commits I make from the glitch console look like this

45

and are not attached to my github user account. How do i fix this?


#2

I think what you’re seeing is that, as things stand, Glitch overwrites parts of your local git config every so often. I’m not sure exactly what the cycle is, but if you looked at git config -l you might see more than one value set and cat .git/config will show you what’s set locally and is being used in the commit messages.

I haven’t tried to set up a credential.helper yet, but for the user.email setting I have a manual process I use to control the commits that includes resetting the user.email value before I commit.


#3

that fixed it thanks, i had set my account info with --global but glitch was overwriting it in --local


#4

I’m working on making this happen automatically for you, but it’s harder than you would think. There’s some infrastructure refactoring happening right now that will make it easier, so I’ll do it after that.