Corrupted project?


#1

Hi!
I made a project some times ago, and it worked perfectly. I don’t know how and why, but yesterday it started to make weird things.
First, it launched, casually, a “EADDRINUSE” error, so I used killall node.
It worked but, then, whenever I make a change to the project, it restarts, redownloads every npm packages causing a “ENOSPC” error and doesn’t save the changes to the project.
I thought that it was because the 128 MB limits of a project, so I removed some npm packages that I don’t use anymore from package.json, but, another time, it restarted, redownloaded all npm packages, throwed a “ENOSPC” error and then didn’t save changes to the package.json.
So I deleted the package.json file, and thought “If I delete and recreate it, it should work!”, but it didn’t work and now when I try to update the package.json file, it restarts again, redownloads all npm packages agains and doesn’t save the changes. So now the package.json file is empty and I can’t edit it.
I tried to use the rewind function, but it doesn’t work : it loads forever and says “Previewing rewind” but there’s no checkpoint that I can select, only loading, forever.
So, can anyone please help me, for example for rewinding the project? I don’t have any idea about how this happened, because it all started randomly, without even changing the project.
The project is “dreamsub-bot” and it was private, but now I made it public to let you see.
Thank you, for every help you will gave me!
And sorry for bad english.


#2

Removing packages from your project won’t help free up space unless your project is using npm. By default, Glitch projects use pnpm and packages don’t count towards your project space. Run ‘enable-pnpm’ to make sure it’s using pnpm, then run git prune and git gc. This will hopefully free up enough space to make it functional again.


#3

I ran enable-pnpm(even if pnpm was already enabled), but then when I run git prune there’s no console output, and when I run git gc the error is

Counting objects: 1732, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (738/738), done.
fatal: sha1 file '.git/objects/pack/tmp_pack_ctH2AN' write error: No space left on device
error: failed to run repack

#4

DM me a join link so we can view the code. Thanks.


#5

I fixed by making a new project. Thank you, anyway! :grinning:
And sorry for wasting your time.


#6

To give you the background on why projects fill up: we take regular snapshots of your project as you edit it so you can roll back changes should you need to. It sounds like this filled your project. By creating a new one you lost the git history so it has more space for now. But to try and stop it from happening again I suggest adding any frequently changing data files to a .gitignore in your project.