Could not find node , using 10


#1

Error: Could not find node , using 10
My package.json:

{
  "name": "commando",
  "version": "0.28.0",
  "description": ".",
  "engines": { "node": "10.0.0" },
    "scripts": {
    "test": "echo \"Error: no test specified\" && exit 1",
    "start": "node Commando.js",
  "author": {
    "name": "Sep",
    "email": "sep"
  },
  "contributors": [
    {
      "name": "SepulturA"
    }
  ],
  "license": "MIT",
  "scripts": {
    "test": "npm run lint",
    "lint": "eslint ."
  },
  "repository": {
    "type": "git",
    "url": "git+https://github.com/WeebDev/Commando.git"
  },
  "bugs": {
    "url": "https://github.com/WeebDev/Commando/issues"
  },
  "keywords": [
    "discord",
    "bot"
  ],
  "homepage": "https://github.com/WeebDev/Commando#readme",
  "dependencies": {
    "Sherlock": "neilgupta/Sherlock",
    "canvas": "next",
    "cheerio": "^0.22.0",
    "discord.js": "hydrabolt/discord.js",
    "discord.js-commando": "gawdl3y/discord.js-commando",
    "erlpack": "hammerandchisel/erlpack",
    "moment": "^2.0.0",
    "moment-duration-format": "^1.0.0",
    "node-opus": "^0.2.0",
    "pg": "^6.0.0",
    "pg-hstore": "^2.0.0",
    "prism-media": "hydrabolt/prism-media",
    "random-js": "^1.0.0",
    "redis": "^2.0.0",
    "request": "^2.0.0",
    "request-promise": "^4.0.0",
    "sequelize": "^4.0.0",
    "simple-youtube-api": "^3.0.0",
    "snekfetch": "^3.0.0",
    "tsubaki": "^1.0.0",
    "uws": "^8.0.0",
    "winston": "^2.0.0",
    "ytdl-core": "^0.17.0"
  },
  "devDependencies": {
    "eslint": "^4.0.0",
    "eslint-config-aqua": "^2.0.0"
  },
  "eslintConfig": {
    "extends": "aqua",
    "rules": {
      "no-process-env": "off"
    }
  }
}

MOD EDIT: formatting


#2

Can you try using another version of node? There is a newer, and more stable version If I am correct!


#3

I’m getting the same error.


#4

Hey @SepulturA I’m not sure if you captured your whole package.json or not, but that content isn’t a valid json file. It’s missing a “}” somewhere, and also (although this doesn’t make it invalid in and of itself) you seem to have two scripts elements. I suggest using https://jsonformatter.curiousconcept.com/ and http://package-json-validator.com/ or similar tools to validate your file and seeing if that helps at all.

You can also wee the currently provided node versions at https://nodeversions.glitch.me, although a problem there won’t typically be an error - it’ll be a WARNing and Glitch will just pick the default Node version anyway.