Could not use Glitch editor when WebGL is unavailable


In Firefox, i got this:


Suspect this is a result of the gltf file previewr not being lazy loaded.

I don’t think so, Yonle describes that this is in the editor and I believe I’ve gotten this error or something similar before with perfectly working code before.

1 Like

Humm, maybe can help?

I’m facing the same error, but only in Google Chrome.

Welcome to the community, @miguelangel-cc! Can you give us your code?

Hi! Thank you @_tr! Sure, I get the errors below in Chrome when I try to open the Glitch editor. I’m on Linux Mint 21 (Vanessa) with XFCE. The Google Chrome version is: Version 107.0.5304.110 (Official Build) (64-bit).

1 Like

Oh, on the Glitch editor! Sorry, I misunderstood.
Try this:

  • Refresh the page
  • Clear cache
  • Try incognito
  • If nothing works, create a ticket on

Actually, my editor works OK

Thank you @_tr. I’ve tried your points but they don’t work :slightly_frowning_face: . I have already sent an email to Does the email work or should I open a ticket in

It works perfectly, no worries! Already reply yet?

Not yet :confused:. I’ll keep waiting and using Firefox (which works well) until I get an answer.

Can you please confirm if this is just a browser issue (all apps are unable to use webgl), perhaps by checking the special debug url chrome://gpu ?

Thank you @javaarchive. Below you can see the first part of my chrome://gpu output.

Find the full output in the following file: Upload files for free - Graphics Feature Status -

Apparently, webgl is enabled, isn’t it? :thinking:

Hmmm it appears your browser should be able to perform webgl however in the file you provided it seems like chrome is doing some workarounds for graphics drivers bugs
Can you confirm if you see a cube on
and also if you see the aquarium of spinning fish on
WebGL Aquarium
This way we can see if the issue is really isolated to just glitch
I noticed in your screenshot “XR” is mentioned so I’m assuming glitch is requesting some WebXR feature it doesn’t need as well and erroring out that.

suggestion for glitch staff: Please lazy load these components until they’re actually needed, thanks :slight_smile: or try putting in a react error boundary to not break the entire app


Dunno know why Glitch editor needs WebGL. Probably due to ThreeJS?

it’s used in the assets viewer, which supports previewing 3d models. would be nice to allow the rest of the editor to work if webgl is missing

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.