Custom Domain Currently Not Working!

Hi all! Thanks for posting about this, and thanks to those of you who wrote to us about this issue. I am looking into it now. As soon as I get an update, I will post it here.


Just worked lol

Thank you! Mine is still not working, also please state the solution if you do fix it so I can mark it as the solution.

Nice to see people are getting their projects back.


We are still investigating this issue, and I have a question for those of you who are still seeing “not found” on a custom domain that was previously working:

Did you use Cloudflare during the custom domain setup process?

We think this may be a common thread, but are not sure. Hence the ask.

I did, but it fixed itself anyway :slight_smile:

It is not working for me too, and yes, I am using CloudFlare, and so is @BLFD, as he told me too.

I use cloudflare.

@tasha I have checked all the website’s that were posted by users in this thread that said not found and all the certificates were from

Thanks all, it is really helpful to get your feedback! Here is an update:

We confirmed that the problem appears to be Cloudflare proxies causing issues with So we won’t be able to fix this for users that have been affected.

However, there is a way that you can get your custom domains working again

  • Remove the proxy, remove the custom domain and then re-add the custom domain back to your project.
  • This does mean that you will have to contact us if you want a custom domain removed. Click here to go to the support form where you can request domain removal. When filling it out, please use the email that is connected to your Glitch account. In the message, let us know the custom domains that you need removed.

You should receive a response within 24 hours if not sooner.

1 Like

Do you mean get rid of cloudflare? @tasha

1 Like

@EddiesTech if you are using their proxy then yes you will need to disable it.

If you just used Cloudflare as your registrar and not for a proxy, then you do not need to stop using Cloudflare to get your custom domains to work.

@tasha Ah, so I can disable the proxy by using that cloud arrow button doodad!
Thanks for the info :slight_smile:


Hello! Will this issue happen again?

If you have your DNS routed/proxied through cloudflare it might not work. If you don’t it will be fixed (e.g. Turn DNS to gray cloud instead of orange)

Is Glix your company?

May I ask how this is considered spam?

Advertising? Glix is yours?

It’s his project designed to help the community. Yes his first post was a bit like an advertisement but he is truly trying to help those who want to use Cloudflare


So by mentioning that something else is working it’s considering spam/advertising? Which means that over a fourth of this forum should be flagged for advertisement? I’m sorry that just sounds ridiculous…