D.js Error Probably An IP Ban error

Everything was going fine , but when i edited the code, The Console Logged me this error

When I Asked In Support Channels, They Told That Maybe The Projects IP is bannned.
Plz do have a look.

Error

[EVENT] /rbd/pnpm-volume/eae8d9d0-cc27-4b63-8a5a-a48ac326a382/node_modules/.github.com/dirigeants/klasa/118844a4c17f433a1e33fc0b2431f273f4a8eca6/node_modules/klasa/src/events/onceReady.js

1:27 PM

[2018-08-09 07:57:00] Error: 404 Not Found

1:27 PM

Jump to

[2018-08-09 07:57:00] at _response.transport.request.then (/rbd/pnpm-volume/eae8d9d0-cc27-4b63-8a5a-a48ac326a382/node_modules/.registry.npmjs.org/snekfetch/4.0.4/node_modules/snekfetch/src/index.js:193:21)

1:27 PM

[2018-08-09 07:57:00] at <anonymous>

1:27 PM

[2018-08-09 07:57:00] at process._tickCallback (internal/process/next_tick.js:188:7)

Is this in your ind project? That’s not the same error we’ve seen previously from IP bans. It reads more like you’re missing a file or are referencing a resource in an incorrect location. Which part of your code causes the error?

Hey @Gareth i opened the glitch editor, my bot restarted and I got an error too, IIRC this one is the one from IP bans. (not sure though)

events.js:167
      throw er; // Unhandled 'error' event
      ^
Error: connect ECONNREFUSED 54.148.61.160:443
    at TCPConnectWrap.afterConnect [as oncomplete] (net.js:1159:14)
Emitted 'error' event at:
    at TLSSocket.socketErrorListener (_http_client.js:382:9)
    at TLSSocket.emit (events.js:182:13)
    at emitErrorNT (internal/streams/destroy.js:82:8)
    at emitErrorAndCloseNT (internal/streams/destroy.js:50:3)
    at process._tickCallback (internal/process/next_tick.js:63:19)

I tried remixing the project and the remix had the error too.

Yeah, that looks more like an IP ban. If you let us know your project name then we can take a look.

The original project is advaithbot, and the remix is sage-error. I’m worried opening another project in the editor will make it break too, is that likely?

Opening projects doesn’t change their IP so it won’t have an impact. If the project you open is already on a worker with a banned IP then it’ll be banned whether you open the project or not.

Well it seems opening it caused it to restart, but maybe it was already broken.

Gareth, did you look into it? Maybe moving it to a different worker/IP would help?

My friend is also having the error on beepbot.

No Its Not iND bot, Ill DM you invite link

Yeah, we’ve confirmed it isn’t due to a banned IP. DM me a join link and I’ll take a closer look at the cause as it’s not clear to me the cause from the error in isolation.

It’s a problem in your code in the file commands/Search/dcs.js - removing it from the commands folder clears up the issue. So check the resources you’re loading in that file and make sure they’re all accessible.

Hey @Gareth, I’m having the same issue as Advaith… My project is beepbot
Any update/solution to the issue?
I can DM you an invite link to edit if you’d like to check it out.

The problem is caused by the code in the functions/engines/botlists.js file, which is common across both yours and @advaith’s projects - though I wasn’t able to confirm in sage-error or advaithbot as neither have currently valid tokens. But it’s a request in botlists.js that causes the error, the bot works fine otherwise.

Thanks, i’ll look into it. :slight_smile:

Thanks a lot sir.! :slight_smile:

I dont think the problem is sorted sir by removing that command

Ok Nvm , it started again on its own

Thanks so much, looks like we were using an outdated version of a package which used a broken API.

1 Like

Glad you got it sorted!

1 Like