Disable autosave?


#1

I just started using Glitch and I like it a lot, but one thing that annoys me is the autosave feature.

It makes it so that the editor automatically saves my code, causing my code to constantly recompile, which is more often an annoyance than it is helpful. It seems to be hard on the server’s resources too, as the container is often in a CPU “warn” state due to the constant recompiling.

Is there anyway to disable this feature?


#2

Hi @tmshkr, welcome to the Glitch forum!

I think what you’re looking for is a watch.json file. You can see one in action with some information at https://glitch.com/~watch-json, but essentially, when properly configured, it will tell Glitch which files should trigger a restart and how often.

Hope that helps. Happy Glitching!