Discord Ban mega-thread! (Discord bot / Something took too long to do)

discord
#22

Hi All!

Cori, a staff member will be fixing this later this morning.

1 Like

#23

It looks like we have a few IP addresses that have been blacklisted. I’ll be working with another Glitch staff member to resolve that on our end in just a little while.

@Codingpro are you saying that Discord is also taking a look at this from their end? Do you have a contact that you’re working with - we’d like to be able to resolve this on a more permanent basis and it would help to know someone who’s already aware of this on the Discord side of things.

0 Likes

#24

Hey Cori!

I didn’t say that, but I could try to find some discord staff to contact. Can I have a status update plz?

Oh I see. I was saying it as you would be looking into it, not that I’m talking to you.

1 Like

#25

I wasn’t sure what you meant by

I’ll be reaching out to them later today to start the process, but if you already had an ongoing contact I was going to try to horn my way into that conversation. If that’s not what you meant then don’t worry about it.

I’m sitting down with someone else on our team to go over our process at 11ET and I think this will be resolved soon thereafter from our end - at least for this instance.

2 Likes

#27

Ok, for some reason, I opened the projects and it installed node v8.14.0 for some reason, and now it seems to work. Very strange for so many people having the same issue and nobody knows the cause…

1 Like

#28

well we know the cause now. Some IPs were being banned.

1 Like

Error: Something took too long to do. [Discord]
#29

Wait same! It works now!

1 Like

#30

Hey folks, sorry for the delayed update; we’ve removed a few of the hosts that Discord had banned so your projects are starting up on new hosts with new IPs that haven’t been banned. That should resolve the existing issues (and has nothing to do with reinstalling). There are a few more hosts that seem to have been banned that we’ll also be cleaning up today, but none of those seem to be related to any of the projects mentioned in the topic.

Additionally as I noted above, we’re hoping to work with the Discord folks to work out a better way to handle this.

3 Likes

#31

Thanks! You really helped!

(I had like 1000s of users waiting on the bot :stuck_out_tongue: )

2 Likes

#32

Hello for me everything seems back to normal thank you to the staff of glitch and Cori

2 Likes

#33

Started again for me…

1 Like

#34

Nevermind. It was fixed.

1 Like

#35

I have the same problem. My bot is DTB-bot

1 Like

#36

Yeah, looks like it struck my bots again, this time on ajota and arashira.

1 Like

#37

This is also happening with my project, nootnootbot

1 Like

#38

Hey folks it looks like we had a host that was temporarily banned but it appears to have cleared up.

Let us know if you continue to see problems.

1 Like

#39

Seemed to have worked for the first few hours, but then my project arashira can’t connect again. The other one that was affected at the same time isn’t having an issue yet.

1 Like

#40

Looks like that host was re-banned. We’ve removed it from the pool so please check again and let us know if you see other problems.

0 Likes

#41

I now have the exact same problem, I am also relatively busy now, so I noticed it around 7 hours after it happened. My project is https://n-emoter.glitch.me, and I hope it gets resolved as soon as possible.

Thanks for your time :slight_smile:

1 Like

#42

Hey @Cikarin3 we had another host banned by Discord. I’ve moved all the projects from this host, so your bot should be up and running again.

Let us know if you have any further problems!

0 Likes