Discord bot çözemiyorum yardımcı olun

internal/modules/cjs/loader.js:584

throw err;

^

Error: Cannot find module ‘discord.js’

at Function.Module._resolveFilename (internal/modules/cjs/loader.js:582:15)

at Function.Module._load (internal/modules/cjs/loader.js:508:25)

at Module.require (internal/modules/cjs/loader.js:637:17)

at require (internal/modules/cjs/helpers.js:22:18)

at Object. (

:17)

at Module._compile (internal/modules/cjs/loader.js:701:30)

at Object.Module._extensions..js (internal/modules/cjs/loader.js:712:10)

at Module.load (internal/modules/cjs/loader.js:600:32)

at tryModuleLoad (internal/modules/cjs/loader.js:539:12)

at Function.Module._load (internal/modules/cjs/loader.js:531:3)
1 Like

Not: Bu mesaj için Google Çeviri’yi kullandım.
(Note: I used Google Translate for this message.)

5 dakika beklemeyi ve günlükleri tekrar kontrol etmeyi deneyebilir misiniz?
(Can you try waiting 5 minutes and then checking back at the logs?)

anlamadım kusura bakmayın açıkca anlatırmısınız

Package.json dosyasında düzenleme yapabilir ve birkaç saniye bekleyebilir misiniz?

tamam bekliyorum :gülen:

size versem düzenleyebilirmisiniz

Hayır, üzgünüm. Herhangi bir harfi değiştirin ve geri değiştirin

Package.json dicord.js 13.5.4 zaten

Bu sorunu düzeltti mi?

**malesef hayır :frowning: **

Package.json dosyasını değiştirmek ve geri değiştirmek ve bir süre beklemek sorunu çözmediyse, nasıl düzeltileceğini bilmiyorum, üzgünüm

tamam sorun değil ilgin için sağ ol :slight_smile:

kardeşim discord.js modülünü indirmemişsin. konsola “pnpm i discord.js” yaz (" " işaretleri olmadan)

npm install to install the packages as mentioned in the packages.json file. :stuck_out_tongue:

app@copper-honey-roundworm:~ 21:23
$ pnpm i discord.js
A store server is running. All store manipulations are delegated to it.
ERROR No matching version found for discord.js@>=14.0.0 <15.0.0
hata alıyorum

Try to use npm i discord.js.

Hi! Glitch uses pnpm so shouldn’t it be:

pnpm i discord.js

I don’t really know, but I have heard of issues with the differences between these

Weird, npm is still working for me without any issue.

Maybe I’m wrong, it’s just from memory :slight_smile:

No problem at all. :stuck_out_tongue: