[Discord Bot] Error: Cannot find module 'merge-descriptors'

This project was working all good some time ago, then I received a message from Uptime Robot (where i host the bot) saying its monitor went down. This bot is temporarily deactivated since then, 'cause i noticed this error in Logs. Any idea on how to solve it?

ERROR  EACCES: permission denied, open '/rbd/pnpm-volume/5d30526c-2b61-4852-ae76-f68ec5ba5e49/node_modules/quick.db/package.json'
internal/modules/cjs/loader.js:584
    throw err;
    ^
Error: Cannot find module 'merge-descriptors'
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:582:15)
    at Function.Module._load (internal/modules/cjs/loader.js:508:25)
    at Module.require (internal/modules/cjs/loader.js:637:17)
    at require (internal/modules/cjs/helpers.js:22:18)
    at Object.<anonymous> (/rbd/pnpm-volume/5d30526c-2b61-4852-ae76-f68ec5ba5e49/node_modules/.registry.npmjs.org/express/4.16.4/node_modules/express/lib/express.js:17:13)
    at Module._compile (internal/modules/cjs/loader.js:701:30)
    at Object.Module._extensions..js (internal/modules/cjs/loader.js:712:10)
    at Module.load (internal/modules/cjs/loader.js:600:32)
    at tryModuleLoad (internal/modules/cjs/loader.js:539:12)
    at Function.Module._load (internal/modules/cjs/loader.js:531:3)

I use quick.db (^7.0.0-b16) module on other projects as well, so it can’t be the problem. Also, I’ve tried installing merge-descriptors and its definitions at the project, but it keeps spamming the same error in Logs.

Hey @Wh1t3W0lf, this sort of error often means that the install step triggered by the twice-daily project restart probably failed. Typically running enable-pnpm in the console resolves this issue - can you give that a shot and let us know how it goes?

1 Like

Hey @cori, thanks a lot for the fast answer.
So, I ran the enable-pnpm in the console as instructed and it seems the bot’s back to work.

image

Tools’ not red anymore. Testing it rn in Discord.

Shots in Logs…

image

Well I’m having some connection issues trying to log in (Discord), but if the project’s presenting these results, much probably it’s working fine. Again, thanks a lot for the help ^^


Feed the capybara! :herb: