Discord Java (.jar) Hosting

Hello There!
Can You please Say Me If i can hot java (.jar bot file) Bot?
Thanks Arnon

Sure you can!


Ok If i’ll get some errors i’ll send here ok?


Sure, I’m so java expert but I’ll do my best.

I Getting this error

Run cd and then run that command.

How To Do That
Can You Send Me The command?

Just open the terminal and run cd, then run the command you just ran (the java one)

Its The Same Thing
I’ll Give You Prems
But What Is Your Discord?

In the Glitch editor, click on Tools (in the bottom left corner), then click on Terminal, and then using your keyboard, type cd and press Enter. Then run the Java command that you want to run.

That Exactly What i did And Its Giving Me The Same Error


Does your project have a file called JMusicBot-0.2.10? Can your run ls and show us the results?

That The Results But I’m not Understand Where Is My .jar File

Hi, are you fine with sharing the source code with us? If so, could you please make your project public and share the link with us to get better assistance?

You will need to download the file into your project.

Run this in the console:

wget linktoyourfile -O nameofyourfile

(replacing linktoyourfile with the url to your file and nameofyourfile with the output name)

wget https://github-production-release-asset-2e65be.s3.amazonaws.com/65681319/a67e2980-be18-11ea-8541-9e9858285869?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20200919%2Fus-east-1%2Fs3%2Faws4_request&X-Amz-Date=20200919T120735Z&X-Amz-Expires=300&X-Amz-Signature=eba10f1873bed4070c6794c4e98598be0d4fea836fee9878967da50894fadf33&X-Amz-SignedHeaders=host&actor_id=58848496&key_id=0&repo_id=65681319&response-content-disposition=attachment%3B%20filename%3DJMusicBot-0.2.10.jar&response-content-type=application%2Foctet-stream -O JMusicBot-0.2.10.jar
[1] 175
[2] 176
[3] 177
[4] 178
[5] 179
[6] 180
-su: X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20200919%2Fus-east-1%2Fs3%2Faws4_request: command not found
[7] 181
[8] 182
[9] 183
[10] 184
–2020-09-20 06:57:42-- https://github-production-release-asset-2e65be.s3.amazonaws.com/65681319/a67e2980-be18-11ea-8541-9e9858285869?X-Amz-Algorithm=AWS4-HMAC-SHA256
Resolving github-production-release-asset-2e65be.s3.amazonaws.com (github-production-release-asset-2e65be.s3.amazonaws.com)… -su: X-Amz-Date=20200919T120735Z: command not found
-su: X-Amz-Expires=300: command not found
-su: X-Amz-Signature=eba10f1873bed4070c6794c4e98598be0d4fea836fee9878967da50894fadf33: command not found
-su: X-Amz-SignedHeaders=host: command not found
Connecting to github-production-release-asset-2e65be.s3.amazonaws.com (github-production-release-asset-2e65be.s3.amazonaws.com)||:443… connected.
-su: response-content-disposition=attachment%3B%20filename%3DJMusicBot-0.2.10.jar: command not found
HTTP request sent, awaiting response… -su: response-content-type=application%2Foctet-stream: command not found
400 Bad Request
2020-09-20 06:57:42 ERROR 400: Bad Request.

[1] Exit 8 wget https://github-production-release-asset-2e65be.s3.amazonaws.com/65681319/a67e2980-be18-11ea-8541-9e9858285869?X-Amz-Algorithm=AWS4-HMAC-SHA256
[2] Exit 127 X-Amz-Credential=AKIAIWNJYAX4CSVEH53A%2F20200919%2Fus-east-1%2Fs3%2Faws4_request
[3] Exit 127 X-Amz-Date=20200919T120735Z
[4] Exit 127 X-Amz-Expires=300
[5] Exit 127 X-Amz-Signature=eba10f1873bed4070c6794c4e98598be0d4fea836fee9878967da50894fadf33
[6] Exit 127 X-Amz-SignedHeaders=host
[7] Done actor_id=58848496
[8] Done key_id=0
[9]- Done repo_id=65681319
[10]+ Exit 127 response-content-disposition=attachment%3B%20filename%3DJMusicBot-0.2.10.jar

That What I’ve Got

Instead of trying to wget the amazon aws url, I think you should upload it to your PC, then upload it to glitch cdn.

That Worked!
And Last Question:
How I’m Doing This Bot Working 24/7 Because he have a custom command to turn it on

You can’t host 24/7 on Glitch, unless you had boosted it with Glitch subscription, and pinging isn’t allowed anymore. You can read more about subscription here.