Discord.js is not a module

Hey im getting this weird error in the title i tried to do
enable-pnpm in the console but it didnt fix it

My packages:

If anyone could help me i would appreciate it.

Not sure if this has anything to do with it, but I noticed two things:

"engines": {
     "node": "8.x"   

Discord.js needs node.js v12 or greater, so change this to “12.x”

"discord.js": "^12.0.1"

The latest version of discord.js is 12.2.0, maybe try a newer version?

Changed it its still the same error

try going to the console and running pnpm search discord.js and see what that gives you

it gives me discord.js in red the description author etc
And other packages but they are all white.

that means it can find the package itself on npm. would you mind PMing me an invite to the project so I can look?

Idk how to use glitch support
But i could find the send message button atleast

aha, i see the problem:
the installation failed for pnpm, here’s the error message:

ERROR  /app/package.json: Invalid version: "1.5.2 - Powered by Lolization LLC"

the version in package.json must be formatted similar to this:

version: "v1.5.2",

or something else that node-semvar can parse

1 Like

Oh alright thank you sir

1 Like

Oh god it went crazy

Could not locate the bindings file

Could you look into it again please?

Welp seems like its gone now
And now i got a another error
Starting inspector on localhost:9200 failed: address not available

ack i was just about to open it up, sorry about that

for this last error:
change the port number in your code from 9200 to process.env.PORT, so glitch can handle that part of it

I cant find it
Could you do it for me?

ill need another invite, I left the project

Sended you the invite

Did you fix it :slight_smile:?

im on right now

yay post needs twenty characters…

1 Like

its working now, it logged that it found the commands and tried to login. make sure you put in your bot token though :wink:

The token is there :slight_smile: