Discord.js not starting (no errors)

Hello there,

I’m going to keep it short and quick:
My bot was working fine, but, suddenly, stopped working. No errors on console, no errors nowhere. Simply doesn’t trigger any event

What I tried:

  • Export, delete, and import project
  • Delete all unnecessary code (keeping only on ready, on message and login)
  • Re-install all packages
  • Only keep discord.js package

I’ve changed nothing in the code (as far as I remember), and the Token is right

The bot is private but I’m making it public for a while: https://glitch.com/edit/#!/oof-the-bot

Any help is appreciated, thanks

EDIT: This seems to be a Glitch issue, as other users are experiencing it. I doubt that the problem is in the code, as it was working fine before

Reading the code, you need to type the command in uppercase for it respond:

    //await handler.handle(msg, client);

Does this code happen when the bot is ready?

console.log(`${client.user.tag} is ONLINE :)`);

Do you see <CLIENT.USER.TAG> is ONLINE :) in the logs?

1 Like

We’re experiencing the same. :confused: Its been almost a day for me.
I did all stuff you tried, I also tried to remixed the project but doesn’t work for me.

1 Like

thanks for replying,
actually no, it makes the original message uppercase so it’s not case sensitive,
but that’s not the problem, it doesn’t even trigger the ready event (so nothing in the console)

SOLUTION for me: regenerated the token and replaced in the bot. I don’t know how but it worked

Not working for me :C