Does not allow py


#1

In my project it does not allow me to download python dependency so rip help


#2

@JaZz python is not fully supported the way Node.js is, but in most cases it works fine.

Can you let us know the dependency you’re having trouble with and what you’ve done so far?


#3

Discord.py js the main problem


#4

Hey @JaZz we’d be happy to try to help, but I think we need some more information. You could start by telling us:

  1. What you did
  2. What you expected to happen
  3. What actually happened (including any error messages you received)

Also it’s often helpful to know what the project name is so folks trying to help can take a look.


#5

Just to add to what @cori said, python as you know is different from nodejs in every way. for you to run and use python on glitch, here are the little DOs that you must perform

  1. goto your project
  2. click on your status
  3. click on the console button
  4. it will take you to another tab

from here you can now run some simple python commands like pip, python, etc.


#6

Ohh the dependence didnt install error was invalid perms check perms by —user