Domain is not working properly

#1

Hey, Ive had the CNAME aded for 72 hours now, and still not working. My domain name is guardian.pw!

using namechep.

#2

can you try pointing the cname to glitch.edgeapp.net?

#3

As Host @Callum-OKane ? Or?

#4

Make it be at the target.

#5

and leave host as it is?

#6

Leave the host as the same things you entered in your project!

#7

What do you mean about that?

#8

Hey @yezzl it looks like your DNS changes haven’t been properly set yet; you can take a look to see what the internet thinks your DNS settings look like using this tool: https://www.digwebinterface.com/?hostnames=guardian.pw&type=ANY&showcommand=on&colorize=on&ns=resolver&useresolver=8.8.4.4&nameservers=

This tells us that the config you have isn’t being sent to the rest of the world because it doesn’t show up in that list, so whether or not it’s correct doesn’t matter that much because no one’s seeing it anyway.

Based on what I think you’re trying to do you may not be able to use a CNAME.The information at https://glitch.com/help/custom-domain/#mydomainnameregistrarneedsanipaddress may be informative.

1 Like
#9

will this work maybe?

#10

I think that should be your A record, not a CNAME, but otherwise looks right.

And I want to point out that @Callum-OKane is correct, you can use glitch.edgeapp.net instead of your *.shw.io domain.

Once you save that, I’d check the Dig Web Interface link I posted earlier in 30 mins or so and that should help determine if it’s getting sent to the internet.

#11

Still does not work

#12

@yezzl

The host has to be what the url for the site will be

If the host is set to “www”, then the site would be viewable at “www.yourdomain.net
and if the host is set to “yourdoman.net” then it would work without anything before the domain like “www”, or “support”.

Then the Target (IP Address), will have to be set to glitch.edgeapp.net

Try getting everything like that and tell me if it works for you then, and if not, show the configuration you have afterwards.

#13

@yezzl given this configuration, you may be able to leave Host blank, and if you’re setting an A record you need an IP, not a domain name - you can find the current IP of glitch.edgeapp.net at https://www.digwebinterface.com/?hostnames=glitch.edgeapp.net&type=A&colorize=on&useresolver=8.8.4.4

#14

Still nothing

#15

@yezzl I think you might need to put a “.” In the Host field. Here’s the domain that you’ve set the A record for: https://www.digwebinterface.com/?hostnames=www.guardian.pw.guardian.pw&type=&colorize=on&ns=resolver&useresolver=8.8.4.4

Here’s what my NameCheap A record DNS config for an “apex” domain (one without a subdomain) looks like:

If you want to use www.guardian.pw, the. You’d want to use “www” in the Host field and you can use a CNAME and the glitch.edgeapp.net address.

#16

Well, this… what IP do I use for the A Record method?

#17

You want the one for the glitch.edgeapp.net domain that I linked to in CNAME and my domain isnt working, above.

#18

Does not seem to be working…

#19

Can someone just tell me what I should put in every single field? http://prntscr.com/nhv4x4

#20

You can leave the host as “www” without the domain at the end.