Editor blanked out file and lost code for the third time


My editor is not blanking out or anything, but I’ve been getting this error in the console of my project during the last few hours:

ERROR: Your project is almost out of disk space (10.3/128 MB).

It's still running but might stop working once you hit the limit. You can fix
this by removing some files and then making an edit in a file to trigger a
project rebuild.

For more help, hit us up at support.glitch.com

Is this suspicious? It seems like I’m only using 10.3 MB?


Thanks for the report. It should be fine if it keeps working. In the meantime we’ll look into making sure that the log message is accurate, it could be having a strange interaction with our disk compression leading to incorrect results.


Hi @braden337,

that error is the way in which we tell you that you’re running out of disk space. It’s probably not clear enough: 10.3/128 MB means that only 10.3 MB are available out of 128 MB, not that you’re using only 10.3MB. We’ll fix the message so that it is clearer :slight_smile:

Thanks for the report!


Thanks @etamponi, I just downloaded the project from the advanced options menu and the folder is only 12.1 KB, does this make sense?

I did have a test sqlite3 database file (that only had 10 rows) in the .data folder, but I deleted it the first time I saw that log message.

I haven’t seen that log message for a while now.

Here are my dependencies (would this have anything to do with it?):

"dependencies": {
    "express": "^4.15.4",
    "sqlite3": "^3.1.9",
    "node-pre-gyp": "^0.6.36"

And here is my disk space:

$ df -BM
Filesystem     1M-blocks   Used Available Use% Mounted on
none              50261M 23513M    24604M  49% /
tmpfs             15332M     0M    15332M   0% /dev
tmpfs             15332M     0M    15332M   0% /sys/fs/cgroup
/dev/rbd2           128M    51M       39M  58% /app
/dev/xvda1        50261M 23513M    24604M  49% /etc/hosts
shm                  64M     0M       64M   0% /dev/shm
udev              15312M     0M    15312M   0% /dev/tty


Hi braden,

the zip file that you download had several files stripped off (like the node_modules and .git folders), which take up a lot of space. If you are not getting the error message in the log, it means that your disk utilisation is fine (as you can see using the df command you posted).

I’ve increased the warning threshold to 97%, and updated the message so that it is clearer.

Check that your .git directory has a reasonable size (it should be smaller that 1MB), otherwise it might be good to remove it (if you don’t care about your git history so far). It will be created again by our auto-commit code.