Editor stopped loading for one of my projects


Hi, I was working on a project earlier, and things seemed to be working correctly. The editor has stopped loading for me in any browser now, regardless of whether I’m signed in or not. Editors for other projects work just fine. Does this problem reproduce for you as well or is there something weird on my end?

Can't use or edit one of my projects today (500/502 errors)

hey rolandcrosby

It looks like your project got stuck, we’ve got it working for you now. We’re currently reworking that part of the architecture to eliminate this issue in the future.



thanks! looks like everything is working again now.


Have several projects that have stopped working (for instance. One thing they all have in common is that they don’t have a proper Node app, instead are just serving static assets (specifically React apps).

Were you in a similar situation @rolandcrosby ?


Nope, my app had a server run by Node (though it did need to be compiled as part of the start script defined in package.json).


Possibly related to Temporary service interruption ?

Are your projects still down?


Hi there! Looks like my project is stuck as well. Editor doesn’t open it and when I try going to the live app, all I get is “Not found”.


Hi Maciej,

I’ve restored your project to the last working state. Let me know if there is something missing – as I don’t see any file in the project.

Thanks for your report!


There was a pretty complete Node.js app with some sensor data in the .data directory, so I’ll try at least recovering it from my github repo.


sorry for the inconvenience! Let me know if you want me to try to restore from an older backup.



I did recover it from Github, but all files, previously either front-end and back-end, landed in the front-end directory, so navigating to the live preview shows project’s root. Is there any way to repurpose the files?

But anyway, maybe please try going back even to a early march backup, since the app was running mostly unchanged during that time.


I can see both sections just fine:

Perhaps after a refresh you can see both sections too.


Yep, indeed it’s fine now. Perhaps for a few minutes after the import it was not yet in the right shape. :wink: Everything is back, together with the data. Thanks!


Editor is hanging again (this time on this project) – can I get a restart?

looks like it restarted, never mind!


Hi, the editor stopped working in the middle of some updates I was making to this project. I just get the “Hmm…We’re having trouble connecting” message. I’d add you as a collaborator, but the “share” dialog doesn’t load either.


The project is set to private so I can’t poke at it, but do you see any errors in the console?


ot-socket.coffee:193: OT socket error socket initialization failed: timed out /edit/#!/pledge:1: Uncaught (in promise) undefined


I know this is an old topic, but my project is also getting the ot-socket.coffee:196 OT socket error socket initialization failed: timed out error and I can’t load it. Its located here. Could anyone provide assistance?


Hi Dillon,

the project loads correctly for me, try refreshing your browser. If it doesn’t help, try to also clear the cache.

Let me know if this solves your issue :slight_smile:


I had the exact same thing happen to me: https://glitch.com/edit/#!/mercury-result

Is there a fix for this, or do we have to post here to get it unstuck?