Editor stopped loading for one of my projects


#21

Hi Mark,

we’re sorry you saw this issue! When did it happen to you? I couldn’t see any error in our logs, and I can connect fine to the project mercury-result.

Anyway, this is typically a transient situation that auto-resolves after a few minutes. But if you are in a hurry, you can post it here and we can help you get unstuck more quickly :slight_smile:


#22

my project has get stucked for more than 2 hours… Can developer help me to unstuck my project?
project link: https://glitch.com/edit/#!/solar-cabin
:sweat_smile::sweat_smile:
Thanks!


#23

Hi @luckywang95,

your project is private, I have restarted it but I cannot check if it got unstuck.


#24

Hi @etamponi,

Thanks! It finally loaded. its time to get back to work…


#25

Dear @etamponi,

very sorry to inform you… my project get stucked again…


#26

Do you allow me to access it to give a closer look?


#27

you just unstucked my project just now? coz i am able to edit something then i saw a warning from firebase on indexing… i quickly solved the firebase indexing, then my project get stucked again… it is ok to access me project. i will add you after it got unstuck. Can you please unstuck it again? Thank you very much…

PS: it keep on showing reconnecting… then having trouble connecting.


#28

If it gets stuck again, you can open the Console (From Project menu -> Advanced Options -> Open Console) and use the refresh command.

We’ll investigate on why the project gets stuck so often!


#29

Thank you! i suspect this issue is due to the ram usage and also the firebase retrieving part. I forgot to index it just now in the firebase database rules. Are there any method to check the ram usage?


#30

Always from the console, you can use top and similar commands. Unfortunately free is not accurate yet.


#31

I’m having the same issue with my project (selective-snowflake). Once in 10 minutes it gets “We’re having trouble connecting” and refreshing not helps. At the moment it didn’t loads at all for 20 minutes. I’ve tried both FF and Chome on Linux. Could you please help.


#32

Hi @theDmitry,

We see the project running, but I can’t connect to the editor either. It might be an out-of-memory problem or something else. I am investigating, I’ll let you know shortly. Thanks for reporting!


#33

I had to restart the project to be able to connect to the editor.

If it happens again, please let us know and we’ll investigate further.

Sorry for the trouble!


#34

thanks for fast reply. It still does not load for me. And the app page https://selective-snowflake.glitch.me/ has 504 Gateway Time-out :confused:

Could you please check it one more time?


#35

Hi @theDmitry,

I think you were getting the 504 because of this unexpected downtime, which should now be fixed.


#36

It works fine now, thanks @etamponi!

[UPDATE]
“We’re having trouble connecting” is back )