Eleventy "[11ty] You are not authorized to perform this operation (via undefined)" error solved

Posting this in case it helps others as I couldn’t find the answer by googling: I ran into an issue yesterday running eleventy with the error log showing only this and nothing else:

node v12.0.0, with pnpm
Performing headless installation
Total install time: 3157ms

[11ty] You are not authorized to perform this operation (via undefined)
[11ty] Original error stack trace:

ie it didn’t even start trying to build the site, although the error message is not very descriptive (is it the internet which is broken?)

It turns out that I had made a silly mistake - my eleventy build calls some data from Airtable via an API. I had changed the name of a table in Airtable which was hardcoded into my API call. Changing my table name back to what it was fixed the issue.

I’m going to remove the hardcoded table name and also try to make it show a better error message!

Hope that helps someone.


Hi, can you please give us your project name?

why do u use eleventy instead of hugo? hugo > eleventy duh

They’re not asking for help, they’re just sharing a bug they ran into (they had posted in another thread about it and moved it here to share with folks).

1 Like

Hi @carlosgarcia26201, we don’t try to make people feel bad about their static site generator choices in here when comparisons are not solicited. If you have an app running Hugo on Glitch that you’d want to share so folks can make the decision if they want, I encourage you to share in our “The Gallery” category on here!

1 Like

This isn’t stack overflow lol

@_tr sure, it is pophist-ssg-test

1 Like

The website seems to be available to me… Try clearing cache? Oh ok after reading @jenn’s explanation I understand thanks :sweat_smile:

I guess it will crash without the correct .env key variables as per above… I can confirm that with them though it works fine, ie the structure is valid! :slightly_smiling_face:

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.