Endless installtion of modules

I’ve recently encountered an issue with my projects modules taking too long to install or just failing to even log anyting about installing a module. Today, I wanted to get back to working on my project (with an >increase by 1 module) and it no longer functions as normal. I tried enable-pnpm - and still it doesn’t work. Was my new module to big for the project to handle? I have gone ahead and audited all the modules I have, but with no avail. All of the modules I have installed on my project are mostly required by my server-side to handle the brains of the whole operation. If I must, I could upgrade to Glitch Pro, but it only gives me the benefit of 400MB of upgraded space. Here’s the attached image!

image

“Terminated” rather looks like it ran out of RAM while installing, as opposed to disk space. Do you maybe have some dependencies that compile large native libraries?

I just remembered, i use “quick.db” for storage which compiles better-sqlite3
Oops. That may be the cause, however - how will I store data now?

Turns out, there must have been a glitch on glitch’s end - i remixed the project, and everything suddenly works like a charm! Thanks glitch for glitching again!
I though still want the old project name, so i’ll either contact support to do a reset then restore a backup

Sometimes you need to run enable-pnpm and enable-npm in the console, which is probably why it fixed when you remixed the project and it generated a new container.

You. are. a. savior! I can’t thank you enough for making my project work once I tried enable-npm. Should’ve looked around the forums for this.

1 Like