Error: Cannot find module 'array-flatten'

Error: Cannot find module ‘array-flatten’
Require stack:

  • C:\Users\user1\Documents\mycelium1\node_modules\express\lib\router\route.js
  • C:\Users\user1\Documents\mycelium1\node_modules\express\lib\router\index.js
  • C:\Users\user1\Documents\mycelium1\node_modules\express\lib\application.js
  • C:\Users\user1\Documents\mycelium1\node_modules\express\lib\express.js
  • C:\Users\user1\Documents\mycelium1\node_modules\express\index.js
  • C:\Users\user1\Documents\mycelium1\app.js
    at Function.Module._resolveFilename (internal/modules/cjs/loader.js:889:15)
    at Module.Hook._require.Module.require (C:\Users\user1\AppData\Roaming\npm\node_modules\pm2\node_modules\require-in-the-middle\index.js:61:29)
    at require (internal/modules/cjs/helpers.js:92:18)
    at Object. (C:\Users\user1\Documents\mycelium1\node_modules\express\lib\router\route.js:17:15)
    at Module._compile (internal/modules/cjs/loader.js:1072:14)
    at Object.Module._extensions…js (internal/modules/cjs/loader.js:1101:10)
    at Module.load (internal/modules/cjs/loader.js:937:32)
    at Function.Module._load (internal/modules/cjs/loader.js:778:12)
    at Module.require (internal/modules/cjs/loader.js:961:19)
    at Module.Hook._require.Module.require (C:\Users\user1\AppData\Roaming\npm\node_modules\pm2\node_modules\require-in-the-middle\index.js:80:39) {
    code: ‘MODULE_NOT_FOUND’,
    requireStack: [
    ‘C:\Users\user1\Documents\mycelium1\node_modules\express\lib\router\route.js’,
    ‘C:\Users\user1\Documents\mycelium1\node_modules\express\lib\router\index.js’,
    ‘C:\Users\user1\Documents\mycelium1\node_modules\express\lib\application.js’,
    ‘C:\Users\user1\Documents\mycelium1\node_modules\express\lib\express.js’,
    ‘C:\Users\user1\Documents\mycelium1\node_modules\express\index.js’,
    ‘C:\Users\user1\Documents\mycelium1\app.js’
    ]
    }

thanks in advance