Error: Cannot find module 'discord.js-musicbot-addon'


#1

When ever I reload the project I gave the same problem:
node v8.11.2, npm 5.6.0

Installing…

npm WARN deprecated tough-cookie@2.2.2: ReDoS vulnerability parsing Set-Cookie https://nodesecurity.io/advisories/130

npm WARN deprecated node-uuid@1.4.8: Use uuid module instead

npm WARN registry Unexpected warning for https://registry.npmjs.org/: Miscellaneous Warning EINTEGRITY: sha1-QFUCsAfzGcP0cXXER0UnMA8qta0= integrity checksum failed when using sha1: wanted sha1-QFUCsAfzGcP0cXXER0UnMA8qta0= but got sha512-zr6QQnzLt3Ja0t0XI8gws2kn7zV2p0l/D3kreNvS6hFZhVU5g+uY/30l42jbgt0XGcNBEmBDGJR71J692V92tA==. (260 bytes)

npm WARN registry Using stale package data from https://registry.npmjs.org/ due to a request error during revalidation.

npm WARN tar ENOSPC: no space left on device, write

npm ERR! cb() never called!

npm ERR! This is an error with npm itself. Please report this error at:

npm ERR! https://github.com/npm/npm/issues

npm ERR! A complete log of this run can be found in:

npm ERR! /tmp/npm-cache/8.11.2/_logs/2018-05-30T06_09_31_240Z-debug.log

module.js:549

throw err;

^

Error: Cannot find module ‘discord.js-musicbot-addon’

at Function.Module._resolveFilename (module.js:547:15)

at Function.Module._load (module.js:474:25)

at Module.require (module.js:596:17)

at require (internal/module.js:11:18)

at Object. (/app/server.js:5:15)

at Module._compile (module.js:652:30)

at Object.Module._extensions..js (module.js:663:10)

at Module.load (module.js:565:32)

at tryModuleLoad (module.js:505:12)

at Function.Module._load (module.js:497:3)

My Package is:
{
“//1”: “describes your app and its dependencies”,
“//2”: “https://docs.npmjs.com/files/package.json”,
“//3”: “updating this file will download and update your packages”,
“name”: “infinity”,
“version”: “1.0.0”,
“description”: “A Discord bot.”,
“main”: “server.js”,
“scripts”: {
“start”: “node server.js”
},
“dependencies”: {
“express”: “^4.16.3”,
“discord.js-commando”: “^0.10.0”,
“snekfetch”: “^4.0.0”,
“discord.music.js”: “^1.0.0”,
“discord.js-musicbot-addon”: “^12.0.1”,
“ffmpeg”: “^0.0.4”,
“node-opus”: “^0.3.0”,
“node-gyp”: “^3.6.2”,
“fs-extra”: “^6.0.1”,
“superagent”: “^3.8.3”,
“figlet”: “^1.2.0”,
“moment”: “^2.22.1”,
“pm2”: “^2.10.4”,
“gif-search”: “^2.0.1”,
“parse-ms”: “^1.0.1”,
“opusscript”: “^0.0.6”,
“ffmpeg-binaries”: “^3.2.2”,
“uuid”: “^3.2.1”,
“discord.js”: “^11.3.2”
},
“engines”: {
“node”: “8.x”
},
“repository”: {
“url”: “https://glitch.com/edit/#!/hello-express
},
“license”: “MIT”,
“keywords”: [
“node”,
“glitch”,
“express”
]
}
Please can someone help…


#2

I have the exact same issue and I also made it a question.


#3

Hello,

the error reports ENOSPC which means that you ran out of space. Run enable-pnpm in the console to make it possible to install packages without taking space in your project :slight_smile: