Error: Cannot find module '@discordjs/form-data'

Error: Cannot find module ‘@discordjs/form-data’

There is an error like this. I tried installing the module but it didn’t work

My project name is saver1

These are errors

internal/modules/cjs/loader.js:613

8:17 PM

throw err;

8:17 PM

^

8:17 PM

8:17 PM

Error: Cannot find module '@discordjs/form-data'

8:17 PM

Require stack:

8:17 PM

- /rbd/pnpm-volume/fecfd883-23bb-487e-9008-ae0159a7315a/node_modules/.registry.npmjs.org/discord.js/12.2.0/node_modules/discord.js/src/rest/APIRequest.js

8:17 PM

- /rbd/pnpm-volume/fecfd883-23bb-487e-9008-ae0159a7315a/node_modules/.registry.npmjs.org/discord.js/12.2.0/node_modules/discord.js/src/rest/RESTManager.js

8:17 PM

- /rbd/pnpm-volume/fecfd883-23bb-487e-9008-ae0159a7315a/node_modules/.registry.npmjs.org/discord.js/12.2.0/node_modules/discord.js/src/client/BaseClient.js

8:17 PM

- /rbd/pnpm-volume/fecfd883-23bb-487e-9008-ae0159a7315a/node_modules/.registry.npmjs.org/discord.js/12.2.0/node_modules/discord.js/src/index.js

8:17 PM

Jump To- /app/main.js

8:17 PM

at Function.Module._resolveFilename (internal/modules/cjs/loader.js:610:15)

8:17 PM

at Function.Module._load (internal/modules/cjs/loader.js:526:27)

8:17 PM

at Module.require (internal/modules/cjs/loader.js:666:19)

8:17 PM

at require (internal/modules/cjs/helpers.js:16:16)

8:17 PM

at Object.<anonymous> (/rbd/pnpm-volume/fecfd883-23bb-487e-9008-ae0159a7315a/node_modules/.registry.npmjs.org/discord.js/12.2.0/node_modules/discord.js/src/rest/APIRequest.js:4:18)

8:17 PM

at Module._compile (internal/modules/cjs/loader.js:759:30)

8:17 PM

at Object.Module._extensions..js (internal/modules/cjs/loader.js:770:10)

8:17 PM

at Module.load (internal/modules/cjs/loader.js:628:32)

8:17 PM

at Function.Module._load (internal/modules/cjs/loader.js:555:12)

8:17 PM

at Module.require (internal/modules/cjs/loader.js:666:19)`Preformatted text`

Please install this as it seems you forgot to install it.
Thanks!
2 Likes

Thanks for your answer, but my console won’t open. I tried installing from package.json but the same error still exists

After further digging on github in this issue. This may be caused by a outdated node version? please correct me if im wrong.

Try updating to node version 12.

my node version is already 12x

I managed to enter the console after a while.Thanks for your interest.