Error: Could not locate the bindings file. Tried:


#1

I just came home and went on glitch getting spammed with

/etc/debugger/node_modules/.registry.npmjs.org/http-proxy/1.16.2/node_modules/http-proxy/lib/http-proxy/index.js:119

throw err;

^

Error: read ECONNRESET

at _errnoException (util.js:1041:11)

at TCP.onread (net.js:606:25)

:beetle: Debugger ready (https://glitch.com/faq#debugger). If the debugger does not open, check your pop-up blocker.

/app/node_modules/bindings/bindings.js:96

throw err

^

Error: Could not locate the bindings file. Tried:

β†’ /app/node_modules/better-sqlite3/build/better_sqlite3.node

β†’ /app/node_modules/better-sqlite3/build/Debug/better_sqlite3.node

β†’ /app/node_modules/better-sqlite3/build/Release/better_sqlite3.node

β†’ /app/node_modules/better-sqlite3/out/Debug/better_sqlite3.node

β†’ /app/node_modules/better-sqlite3/Debug/better_sqlite3.node

β†’ /app/node_modules/better-sqlite3/out/Release/better_sqlite3.node

β†’ /app/node_modules/better-sqlite3/Release/better_sqlite3.node

β†’ /app/node_modules/better-sqlite3/build/default/better_sqlite3.node

β†’ /app/node_modules/better-sqlite3/compiled/8.4.0/linux/x64/better_sqlite3.node

at bindings (/app/node_modules/bindings/bindings.js:93:9)

at Object.<anonymous> (/app/node_modules/better-sqlite3/lib/database.js:4:40)

at Module._compile (module.js:573:30)

at Object.Module._extensions..js (module.js:584:10)

at Module.load (module.js:507:32)

at tryModuleLoad (module.js:470:12)

at Function.Module._load (module.js:462:3)

at Module.require (module.js:517:17)

at require (internal/module.js:11:18)

could someone please help, cheers


#2

Try the following:

Solution
  • npm i node-gyp
  • cd node_modules
  • node-gyp rebuild
  • npm i package-name

Thanks,
~ Bolt. I have fixed my error using this method.


#3

I am still getting this error (enable-pnpm and updating node doesn’t fix the issue.)


#4

Hi @mentalmac9,

can you tell me the project name so I can take a look?


#5

the project is private so i will dm you an invite.


#6

Hi :slight_smile:

it should be fixed now. I’ll make sure to fix the underlying issue so this problem doesn’t show up in the future! Thanks :slight_smile: