ERROR EACCES: permission denied

One of my glitch projects built on Koa.js threw an error out of the blue (I hadn’t changed the code itself and was using it as reference for another project).
Apparently, the koa module had gone missing, but it exists in the package.json file. When attempting to run pnpm install, I end up with the following error:

ERROR  EACCES: permission denied, symlink '../../../accepts/1.3.5/node_modules/accepts' -> '/rbd/pnpm-volume/0d1dc72c-27cc-4eff-9bcd-e771759caed1/node_modules/'

Does anyone have any clue what’s going on here? My other projects seem to be fine though.

Getting the same type of error, with a project of mine, as well, and yes the rest of my projects are fine too, this seems to lead me to believe its a host issue, Try a remix and see if that resolves the issue. (I am trying this ASAP as well. )

A bit of an update: I remixed the project, and as soon as I did the old one worked, so I just went back to coding, it looks like its just a server error, not much we can do, other than remix into a new workspace.

Try running refresh from the console. It may fix the error, thus you won’t have to remix the project.

Running refresh doesn’t work because the server error happens during installation. Refer to error log above.

Hey @huijing I was able to reinstall the packages on a remix of by running enable-pnpm in the project’s console. This forces a reinstall of the project’s packages and resolved the koa installation error.

Can you try that and let us know how it goes?


Oooo, that worked. Thank you so much!

1 Like

I made a new Thread, I seem to be having some issues beyond the error that we was discussing here, after fixing that original issue I am now getting a warning that I am close to out of disk space, which my beta version (seperate project) has the identical amount of files if not more.