Error: EIO: i/o error, read


#1

My app has not been working and I’ve been getting the following error in console:

fs.js:675

  return binding.read(fd, buffer, offset, length, position);

                 ^


Error: EIO: i/o error, read

    at Object.fs.readSync (fs.js:675:18)

    at tryReadSync (fs.js:540:20)

    at Object.fs.readFileSync (fs.js:575:19)

    at Object.Module._extensions..js (module.js:662:20)

    at Module.load (module.js:565:32)

    at tryModuleLoad (module.js:505:12)

    at Function.Module._load (module.js:497:3)

    at Module.require (module.js:596:17)

    at require (internal/module.js:11:18)

    at Object.<anonymous> (/app/node_modules/google-auth-library/node_modules/request/request.js:11:12)

and I think it’s a problem with Glitch. Anyone know how to fix it?


#2

My app is working again. I didn’t do anything to it however.


#3

Sorry about that, we had a brief outage earlier. We’re looking into the root cause.


#4

I’m currently facing this issue.


#5

I am currently having this problem. Assuming it is caused by an outage. I have tried everything I can do.


#6

Update in the status of my project after the last reply I sent: the same error still goes through. I have tried several things, including starting a new project with the same files. (To no avail…)


#7

@GlitchyPSIX, @DrOctavious,

Can you share your project names with us? Otherwise it’s very difficult to figure out what is going on.

Thanks!


#8

Oh, checked right now and the problem somehow was fixed. (Didn’t do anything either)
Guess it was a remnant of the outage or something.


#9

It was resolved an hour after I reported it. As Glitchy says, it may have been a remnant of the outage or something. Thank you.


#10

I’m also facing this issue now, only on one project. Was working fine until this morning, after which no changes were made. Another project is working fine though.
Why is it affecting only one project then, that wasn’t edited at all until it was last working?


#11

Sorry about that - Please provide the project name so that we can take a look into it for you.


#12

Astonishing Hardhat, thanks!


#13

Never mind, I managed to sort it out by deleting the node_modules folder and then reinstalling