"Error: EIO: i/o error, read"


#1

I am getting the following error in console:

fs.js:675

  return binding.read(fd, buffer, offset, length, position);

                 ^


Error: EIO: i/o error, read

    at Object.fs.readSync (fs.js:675:18)

    at tryReadSync (fs.js:540:20)

    at Object.fs.readFileSync (fs.js:575:19)

    at Object.Module._extensions..js (module.js:662:20)

    at Module.load (module.js:565:32)

    at tryModuleLoad (module.js:505:12)

    at Function.Module._load (module.js:497:3)

    at Module.require (module.js:596:17)

    at require (internal/module.js:11:18)

    at Object.<anonymous> (/app/node_modules/google-auth-library/node_modules/request/request.js:11:12)

It is not happening in any of my other projects and I have no idea what is causing it. I have reported this same error before, but it resolved itself last time. Should I see if it does the same this time?


#2

Please provide the name of your project so that we can look into the cause of the issue for you. Thanks.


#3

The name of my app is “ben10bot”
I will send a link


#4

This appears to be happening in apps that use the fs module, since I am using it too and I’m currently facing this issue (It’s been a few hours now)


#5

update: reinstalled all my packages (got a few errors fsr) using npm i and I no longer face the issue


#6

I have the same problem. Did you use the command console or the package.json ?


Problem with fs.js
#7

Command console, if I tried to edit the package.json it’d say that the modules that I modified didn’t exist for some reason.
npm i refetches the files afaik so
update: apparently should use npm install instead


#8

This problem is typically due to the fact that the disk is almost full.

Moreover, running npm i is not supported and might cause issues. Run npm install instead.

Check how much disk space you have with df -h /app. If you still have issues, share your project name or it is very difficult to provide help.


Random fs error
#9

in my case I only have 18% used
Thanks for telling me about npm i though


#10

I got the same, and i don’t know what i have to do !


#11

Check how much disk space you have with df -h /app. Let us know how much along with your project name and we’ll take a look. Thanks.


#12

Try to enable-pnpm or rm -rf .git


#13

This thread is the top google result for the topic, so I’m including a link to the most complete solution: [HOWTO] Fix: EIO: i/o error, read
h/t to Mellon, etamponi, and the Glitch team.