Error in logs: src/system/ line 4: .apache2/ No such file or directory

I get this error, which is why my project does not start. What could be the problem? How to fix it?

My project - Glitch :・゚✧

src/system/ line 4: .apache2/ No such file or directory

In file src/system/, line 4:

The file .apache2/ does not exist

what should I do?

I think you need to create a .apache2/ (unknown contents) or delete that line. But you can also check this website or something like it.

I added the file and also deleted the 4th line in Deleting the line did not help in any way. When adding a file, an error occurred -
src/system/ : line 4: .apache2/ : Permission denied
If you add a file and delete a line, there will be no errors in the logs, but the project has not started. And so there is nothing on the Internet, this error is only with Glitch

You can try creating the file (not deleting the line) and searching the internet to what to put there. Like “Apache2 sh run file” or “Apache2 contents”

It sounds like you don’t know what the original purpose of that script was. If that’s the case, see if you can get in contact with the author of the project that yours is remixed from. There are a few apache related starters posted in this forum. Do you remember which one you used?

Initially I made a remix of the Glitch project –!/lamp-poc to make the site work in PHP

I remixed that lamp-poc project that you linked to. that file has this contents:

#!/usr/bin/env bash

export APACHE_LOCK_DIR=/tmp
export APACHE_RUN_USER=app
export APACHE_LOG_DIR=log

if [ ! -d /app/.apache2/log ]; then
  mkdir -p /app/.apache2/log


I wonder how your project lost that file

1 Like

I inserted this content. I have an error in the logs after that — src/system/ : line 4: .apache2/ : Permission denied

you’ll have to chmod +x it

Error: src/system/ .apache2/ /usr/bin/env: bad interpreter: Text file busy

oh yeah you gotta run refresh or the editor will have some kind of exclusive lock on it :person_facepalming:

Error: apache2: Could not open configuration file /etc/apache2/apache2.conf: No such file or directory
When I uploaded the project, there was a directory .apache in which one file — So I need to restore all the files?

the lamp-poc project definitely has a bunch of other files in .apache/.

so what happened before you uploaded? you had a local copy without these other files? where did that come from? and at some point in the past in was a remix of lamp-poc?

I do not know where all the files in the directory have gone .apache from my project. To start the project, I made a lamp-poc remix, after which I started working on the PHP site. Errors were detected in the logs, after which I corrected them. So, in order to fix another strange error in the logs, for which I incidentally made a separate topic, I could not fix it and at one point another error appeared instead of this error, after which I had to create another topic on this forum.
Past topic: Error in logs: .apache2/ line 12: 77 Terminated apache2 -DFOREGROUND.
Past error: .apache2/ : line 12: 77 Terminated apache2 -DFOREGROUND

The problem is solved, how to close the topic?
I had to make a remix of “lamp-poc” and transfer files from the old project.
Thanks for the help

1 Like

Select a message as a solution and it will mark the topic as solved. :slight_smile:

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.