Error when deploying to Firebase

I added a firebase.json file:

image

and attempting to use the Deploy to Firebase button, I get the following error message in the console:

Deploying to Firebase...
/bin/sh: 1: node_modules/.bin/firebase: not found
Please try again. If problem persists please post on https://support.glitch.com

image

I added firebase via the package.js file and even attempted npm i firebase in the console, all with the same effect.

Can you try remixing one of the pre-existing firebase projects?

1 Like

Could you try running:

pnpm install firebase

as npm has not been working lately on some Glitch projects.

I tried

pnpm install firebase

but that didn’t solve the issue. I attempted remixing an existing firebase project and saw that it worked. Rather than remix it and copy my work over, I attempted to clean out my project, running the following commands:

pnpm prune
pnpm remove
pnpm install (didn't work)
npm install
npm audit-fix <-- Because the previous step recommended it
pnpm prune

That seemed to do the trick (but don’t know exactly why).