ERROR: Your project is out of disk space


#1

Hi,
I am trying to figure out why my app is giving me this error in the log:

ERROR: Your project is out of disk space (used 128 out of 128 MB).

When I check disk usage in the console it reports 47M:

app@stock-tracker:~ 13:12 
$ du -hs
47M     .

And most of that is in node_modules. The app doesn’t write anything to disk.
How can I debug this error?


#2

Items in node_modules counts towards your disk usage. Try a df and see what the /app usage is. Glitch takes automatic snapshots of projects, so it’d be worth checking out the size of your .git directory as that might be using up space. But your .gitignore looks pretty comprehensive, and if you aren’t writing to disk, then it very well may be a bug. Does it still give you the error if you remix your project? It didn’t for me, so if it’s actively blocking your development, then that’s a quick work around.


#3

Thanks for the quick reply.
df shows /app is using 35%

app@stock-tracker:~ 13:56 
$ du -hs .git
240K    .git

app@stock-tracker:~ 14:00 
$ df
Filesystem     1K-blocks     Used Available Use% Mounted on
none            51467016 22262752  27007744  46% /
tmpfs           15698996        0  15698996   0% /dev
tmpfs           15698996        0  15698996   0% /sys/fs/cgroup
/dev/rbd41        131072    31984     61760  35% /app
/dev/xvda1      51467016 22262752  27007744  46% /etc/hosts
shm                65536        0     65536   0% /dev/shm
udev            15679112        0  15679112   0% /dev/tty

The app seems to work normally without errors when it starts, but then the disk space errors start rolling in.
Or not, I’ve just been playing with it and I’m not getting errors now…


#4

Yeah, we’re looking into it. I saw similar behaviour when testing later - temporary full disk usage, flicking back to normal. I’ll let you know when we figure it out. Sorry for the hassle!


#5

Just want to add that the same error is happening on our project: https://glitch.com/edit/#!/co-ment. I am seeing 39M reported from du -hs. The error comes and goes, and we can’t replicate it on demand…


#6

I’m having this same problem. The error appeared after I left my project open for a long time and then came back and tweaked one thing, causing a reload.


#7

I symlink’d to /tmp. It was fixed for a while. Now I’ve been able to keep the error at bay by cutting out my dependencies, then adding them back in when it reappears.


#8

Just to update this issue: unfortunately, it seems newer filesystems like btrfs don’t play nicely with df, so we’re actively looking into possible solutions and should have this resolved soon.


#9

Have you tried “npm cache clean” and “yarn cache clean” ?
I had this error previously, but I can’t specifically remember how I unlocked the situation… :frowning:


#10

A “solution”, until we fix the underlying issue, is the following:

  1. Open the Terminal (Project menu -> Advanced Options)
  2. In the Terminal, run:
    rm -rf node_modules
    sync -f .
    refresh
    
  3. This will cause the editor to reconnect to the project, and the dependencies of the project to be redownloaded and reinstalled, so it might take a few seconds.

Typically, after all these steps the filesystem should report less disk usage (except if the error is legit and you actually need to free up space).


NPM express package not working
#11

rm -rf node_modules
sync -f .
refresh

seems to have worked for me, thanks!
if necessary for your debugging; this is the project https://glitch.com/edit/#!/zillow-trello-powerup


#12

I’m seeing a similar problem, where the logs report “ERROR: Your project is out of disk space (used 127.8 out of 128 MB).” but df -h shows “/dev/rbd10 128M 95M 68K 100% /app” (i.e. it’s reporting 100% usage at 95M).


#13

try doing du -sh and see the space it reports


#14

I noticed a big .package.json.swp file in /app. I deleted that and freed up a bunch of space.